Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-29-2013, 12:07 AM   #1
omar480
Scooby Newbie
 
Member#: 306580
Join Date: Jan 2012
Chapter/Region: SWIC
Location: Tempe, Arizona
Vehicle:
2011 WRX - Hatchback
Silver

Default Light throttle Jerking

Hello, i have been experiencing some jerking when i am light on my throttle pedal, this usually happens on low RPMS 2000 - 3000. What could possibly be the problem ? also when i look at the rpm, i see it fluctuating untill i push more on the pedal ( about 1/3 of the way ), then it stops the jerking.

This issue has made it very uncomfortable to drive. not sure if it could be an electrical or transmission issue but i certainly treat my clutch and transmission really well.

I currently have a 2011 WRX stage+2 pushing 325 whp on stock turbo. i have professionally changed my spark plugs 1 time to one step colder ( if it could be relevant ), its been happening since then.
* Registered users of the site do not see these ads.

Last edited by omar480; 01-30-2013 at 12:50 PM.
omar480 is offline   Reply With Quote
Old 02-25-2013, 01:01 AM   #2
04SILVERBULLET
Scooby Newbie
 
Member#: 333881
Join Date: Oct 2012
Chapter/Region: MWSOC
Location: northern west
Vehicle:
04 subaru
silver

Default

i dont kno if uv solved this issue yet but i had the same issue and i fixed it with seafoam in the gas take fill her up and dump a whole can of seafoam drive it around and vuala well at least this worked for me cleans out the injectors
04SILVERBULLET is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.