Welcome to the North American Subaru Impreza Owners Club Saturday April 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-01-2004, 03:46 PM   #1
Hotrodguru
Scooby Guru
 
Member#: 37210
Join Date: May 2003
Chapter/Region: TXIC
Location: Texas | New York
Vehicle:
2002 Tarmac Bugeye
2012 Hyundai Veloster

Exclamation NEED HELP! WTB: Oil Pan Drain Plug w/ Oil Temp Sensor

PLEASE HELP!

Alright, here's the scoop. I have a 2002 WRX and have the OEM
PERFORMANCE GAUGE PACK ASSY-TURBO that's an option. It displays engine boost, voltage and oil temperature and sits where most WRX's have the clock. Well there is a wire that runs from the OIL TEMP gauge down to the oil pan, it's 2 parts. 1 wire from Gauge to midway ending in a female connector, then the 2nd part is the male connector I think that goes to the OIL PAN Drain Plug. The wire is BUILT IN to the drain plug.

Anyway, the wire just happened to be rubbing on the uppipe because a tie down came undone. The wire is burnt through and my gauge doesn't work anymore. The dealer says it's NOT AVAILABLE and I have to order the whole GAUGE PACK $700 YEAH RIGHT! Does anyone know where I can locate the wire running all the way down from the gauge to the drain plug???

I could just cut and splice but then you could change out the crush washer everytime you change the oil.

Needing HELP! Thanx, Guru
* Registered users of the site do not see these ads.
Hotrodguru is offline   Reply With Quote
Old 01-01-2004, 09:14 PM   #2
wrx320
Scooby Specialist
 
Member#: 28631
Join Date: Nov 2002
Location: on vacation
Vehicle:
2002 WRB wrx wagon
AVO stg I,II Shiv ECUtek

Default

Your dealer is giving you a runaround (reach around) you can buy just the sensor but it is bank. about $150+. The wire shouldn't be able to touch the uppipe. If the dealer installed the guage pack, make them pay for the sensor as the factory installation instructions clearly show the wire exiting the firewall then going over to the DRIVER side of the car and down to the bottom side of the engine then across the crossmember to the oilpan. It should never be able to touch the uppy on the passenger side of the motor. Hope this helps.
wrx320 is offline   Reply With Quote
Old 01-01-2004, 09:41 PM   #3
Hotrodguru
Scooby Guru
 
Member#: 37210
Join Date: May 2003
Chapter/Region: TXIC
Location: Texas | New York
Vehicle:
2002 Tarmac Bugeye
2012 Hyundai Veloster

Default

Yeah thanx alot, sure does help. Well truth be told, I purchased the OEM Gauge set off of EBAY , got it for about $220 and I was pretty happy. I actually did run the wire right under the uppipe and tied it down with a zip tie. Well I did that because the wire's not too long and it looked cleaned installed under the uppipe. There was about 2" between the crossmember and the uppipe and didn't actually anticipate the zip tie coming undone. ALRIGHT, ALRIGHT enough about the install I'll know this next time around. So do you think the wire is also available???

Guru
Hotrodguru is offline   Reply With Quote
Old 01-01-2004, 10:18 PM   #4
WRX Jim
Scooby Specialist
 
Member#: 22321
Join Date: Aug 2002
Location: Germantown MD
Default

is it just a regular electrical wire?

or what is it?

check summitracing.com, i bet they have it.
WRX Jim is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrxtra oil pan drain oil temp sensor kinger Interior/Dressup/Audio & Security 0 10-20-2009 10:20 AM
FS: 04 oem oil filters and oil pan drain plug slvr bullet Engine/Power/Exhaust 2 12-04-2008 12:33 AM
Where to get an Oil Drain plug for oil temp sensor ? (HKS CAMP) Extraze Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 08-27-2004 03:35 PM
Residual oil leak at oil pan drain plug?? DanZ Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 04-08-2004 10:27 PM
WTB!! NEED HELP! Oil Pan Drain Plug w/ Oil Temp Sensor Hotrodguru Texas Impreza Club Forum -- TXIC 5 01-02-2004 12:50 PM


All times are GMT -4. The time now is 11:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.