Welcome to the North American Subaru Impreza Owners Club Thursday May 5, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-30-2013, 12:47 AM   #5001
japstaboi
Scooby Newbie
 
Member#: 350479
Join Date: Mar 2013
Default

would an 05 sti sping and strut fit on 05 forester ll bean?
* Registered users of the site do not see these ads.
japstaboi is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-30-2013, 09:50 AM   #5002
labcoat
Scooby Specialist
 
Member#: 33629
Join Date: Mar 2003
Chapter/Region: MAIC
Location: it keeps changing ,VA
Vehicle:
03 WRX Wagon
WR Blue

Default

Quote:
Originally Posted by japstaboi View Post
would an 05 sti sping and strut fit on 05 forester ll bean?
Spring yes Strut no.

You need 04 STi struts.

R-
labcoat is offline   Reply With Quote
Old 03-31-2013, 03:43 AM   #5003
japstaboi
Scooby Newbie
 
Member#: 350479
Join Date: Mar 2013
Default

Quote:
Originally Posted by labcoat View Post

Spring yes Strut no.

You need 04 STi struts.

R-
ok thank you. i just purchased 05 sti swift springs for $120. does anyone know where i could get 04 sti struts?
japstaboi is offline   Reply With Quote
Old 03-31-2013, 09:21 AM   #5004
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Quote:
Originally Posted by japstaboi

ok thank you. i just purchased 05 sti swift springs for $120. does anyone know where i could get 04 sti struts?
Classifieds here or long list of other wrx/sti forums
Craigslist
Dealer (bend over)

If you can't find any used, post a wtb in classifieds.
JonnyV2889 is offline   Reply With Quote
Old 03-31-2013, 11:58 AM   #5005
japstaboi
Scooby Newbie
 
Member#: 350479
Join Date: Mar 2013
Default

Quote:
Originally Posted by JonnyV2889 View Post

Classifieds here or long list of other wrx/sti forums
Craigslist
Dealer (bend over)

If you can't find any used, post a wtb in classifieds.
what do you mean as bend over hahahah. and ya i have checked classifieds and the postings on forums but most of the struts are sold quick
japstaboi is offline   Reply With Quote
Old 03-31-2013, 04:58 PM   #5006
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

Quote:
Originally Posted by japstaboi View Post

what do you mean as bend over hahahah. and ya i have checked classifieds and the postings on forums but most of the struts are sold quick
Bend over and bite the pillow. They're going in dry.


Meaning, the dealer will charge you a LOT of money for those struts.
Psychoreo is offline   Reply With Quote
Old 03-31-2013, 05:57 PM   #5007
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

^lmao! F the dealer. Subarupartsdepot.com has the cheapest oem parts I found.
mrxr250rider is offline   Reply With Quote
Old 04-03-2013, 01:43 PM   #5008
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

I gut a question for you suspension gurus. I just put some bc coilovers on my 05 wrx wagon. Its pretty low. Its making a weird noise , only when i take a haard right turn. At first i thought it was tires rolling but the more i investigated it, i figured that def wasnt it. Any one have a related situation or know what could cause this?
Zwilks14 is offline   Reply With Quote
Old 04-03-2013, 01:54 PM   #5009
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Quote:
Originally Posted by Zwilks14
I gut a question for you suspension gurus. I just put some bc coilovers on my 05 wrx wagon. Its pretty low. Its making a weird noise , only when i take a haard right turn. At first i thought it was tires rolling but the more i investigated it, i figured that def wasnt it. Any one have a related situation or know what could cause this?
Rear? Front? Wheel/Tire specs? Fender rub?
JonnyV2889 is offline   Reply With Quote
Old 04-03-2013, 03:02 PM   #5010
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

How low was the drop? Maybe if you lift the right side of ur wagon and get underneath and see whats going on compared to the other side. I wonder if the rub could be due to the extra weight of you being on the left side as well as ur battery is all extra weight compared to the right. If you went "that" low haha but i doubt it

Last edited by kantthinkofasn77; 04-03-2013 at 03:08 PM.
kantthinkofasn77 is offline   Reply With Quote
Old 04-03-2013, 04:21 PM   #5011
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

No its not rubbing, thats why im confused. Its. A 17x7. 205 40 17
Zwilks14 is offline   Reply With Quote
Old 04-03-2013, 04:26 PM   #5012
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

I took it back to the shop and installed it to make sure all the bolts in the preload was correct and that isn't the issue. It's only when I'm at speed The owner of the shop I took it to tensed think that if he raises it up a little it might solve the issue but he is on sure he thinks because the control arms I now to get Auldwood it could be causing the issue is not that he thinks he might have something to do with the all-wheel-drive. I'm hoping that's not the issue
Zwilks14 is offline   Reply With Quote
Old 04-03-2013, 04:45 PM   #5013
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

That last one's grammar has me all confused haha sorry..
kantthinkofasn77 is offline   Reply With Quote
Old 04-03-2013, 05:05 PM   #5014
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

Yea sorry about that im doing talk to text on my phone because im driving
Zwilks14 is offline   Reply With Quote
Old 04-03-2013, 05:53 PM   #5015
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

Quote:
Originally Posted by Zwilks14 View Post
Yea sorry about that im doing talk to text on my phone because im driving
Figured something was going on hah as far as damage to your awd system ive read on here somewhere that lowering wont effect ur awd system or damage it. But for sure idk

Last edited by kantthinkofasn77; 04-03-2013 at 05:59 PM.
kantthinkofasn77 is offline   Reply With Quote
Old 04-03-2013, 07:02 PM   #5016
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

I hope not man, this car is killing me man i havent stopped fixing it since i got it, i hope its nothing bad
Zwilks14 is offline   Reply With Quote
Old 04-03-2013, 07:41 PM   #5017
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

What other repairs have you had to do? And when you make the right turns how fast and hard are you turning in your best description?
kantthinkofasn77 is offline   Reply With Quote
Old 04-03-2013, 08:37 PM   #5018
Krang
Scooby Specialist
 
Member#: 134272
Join Date: Dec 2006
Chapter/Region: HIIC
Location: Kailua, Hawaii
Vehicle:
2002 WRX Wagon - WRB
ej207 v8 vf37

Default

2002 WRX Wagon

Suspension:
Feal 441 Coilovers
WL 24mm Front Sway set to full stiff
WL 24mm Rear Sway set to full soft
KB Endlinks F+R
Sti Aluminum Front Control Arms
WL Roll Center kit
TruHart Adjustable Lat Links + Trailing Arms
Every TIC Bushing Available
17x8 BBS RG-R w/ Hankook RS3 225/40/17

12.75" front ride height
13" rear ride height

-2.8 degrees front 0 toe
-1.5 degrees rear 0 toe


Last edited by Krang; 04-03-2013 at 10:54 PM.
Krang is offline   Reply With Quote
Old 04-03-2013, 10:36 PM   #5019
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

Quote:
Originally Posted by kantthinkofasn77 View Post
What other repairs have you had to do? And when you make the right turns how fast and hard are you turning in your best description?
Nothing suspension wise,i did just purchase the coilovers, but in just the last 3 months ive had to do power steering pump, tbelt n water pump, ac tensioner, and fix a frozen toe bolt. Car just hit 80k. Doesnt matter how fast it seems as long as im going. Like parking lot manuevers its fine, but on the road it doese it.
Zwilks14 is offline   Reply With Quote
Old 04-04-2013, 01:06 AM   #5020
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

^^^^ i meant to put this in my previous post but can you determine if its front or rear, the noise. Are you in socal by any chance.. Id be down to do a ride along. Or maybe post a video of the noise. Really need to hear if its metal on metal or plastic on plasic etc..

Last edited by kantthinkofasn77; 04-04-2013 at 01:13 AM.
kantthinkofasn77 is offline   Reply With Quote
Old 04-04-2013, 10:40 AM   #5021
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

At forst i thought it was the front, but now im starting to think its the front and rear. And i live in Boston, really appreciate your offer to help though!
Zwilks14 is offline   Reply With Quote
Old 04-04-2013, 12:46 PM   #5022
kantthinkofasn77
Scooby Newbie
 
Member#: 220808
Join Date: Aug 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 WRX Wagon
Silver

Default

Really need a very descriptive noise.. Post a vid or write a book about it. Its pretty hard diagnosing a car over the internet
kantthinkofasn77 is offline   Reply With Quote
Old 04-04-2013, 01:15 PM   #5023
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

how do i post a video on here?
Zwilks14 is offline   Reply With Quote
Old 04-04-2013, 01:18 PM   #5024
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

Here is a pic of the ride height im at...



Zwilks14 is offline   Reply With Quote
Old 04-04-2013, 01:20 PM   #5025
Zwilks14
Scooby Newbie
 
Member#: 336694
Join Date: Nov 2012
Chapter/Region: NESIC
Location: Boston
Vehicle:
2005 Wrx wagon
Gray

Default

also the shop that installed them i had them check it out and they said that the rear fender lining was rubbing, but they dont think that is the isue of all the banging noise im experiencing
Zwilks14 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The HID FAQ Thread - Read before posting your questions dithergizzard Electrical & Lighting 669 04-26-2016 08:06 AM
What does your rim/tire combo weigh? Post your setup + weight Trevor723 Tire & Wheel 42 06-04-2010 10:40 PM
Post your setup... az ej20 fan South West Impreza Club Forum -- SWIC 20 02-10-2004 11:59 PM
Are these gauge readings correct? post yours too please! T33 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-28-2003 01:35 PM

All times are GMT -4. The time now is 10:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.