Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-21-2004, 08:12 PM   #1
Bumble Bee 03
Scooby Specialist
 
Member#: 25448
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: u know where i live...
Vehicle:
'09 Forester 5MT
'11 Outback 6MT

Exclamation McCulloch HID problem HELP!!!

My right hid light is not working, i check the bulb, its good
I think that the ballast and ignitor are bad, I got the kit for no more than 2 months.... I bought it from another nasioc member and the kit was new... anyone knows where can i get the ballast, maybe someone has that for sale??? I will post also in wanted section
PLEASE HELP
Peter

p.s
the kit is H1
* Registered users of the site do not see these ads.
Bumble Bee 03 is offline   Reply With Quote
Old 01-21-2004, 10:07 PM   #2
brunetmj
Scooby Specialist
 
Member#: 8023
Join Date: Jul 2001
Location: Way-upstate , NY
Vehicle:
2004 2.5 RS

Default

Could you say a little more about how you have them wired. Are the grounds for the ballast wired directly to the battery ground or too chassis? Not to car harness ground?
brunetmj is offline   Reply With Quote
Old 01-21-2004, 10:20 PM   #3
Bumble Bee 03
Scooby Specialist
 
Member#: 25448
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: u know where i live...
Vehicle:
'09 Forester 5MT
'11 Outback 6MT

Default

I connect the grounds to the connections from the harness, they both was workin perfectly... I took the bulb and connect it into the workin headlight and the bulb is ok, i took the ballast out, and put it straight to the battery and nothing, when i took the workin one and put it straight to the battery it was workin
There is power comin into the ballast but nuttin coming out...

Peter
Bumble Bee 03 is offline   Reply With Quote
Old 01-23-2004, 06:54 AM   #4
Bumble Bee 03
Scooby Specialist
 
Member#: 25448
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: u know where i live...
Vehicle:
'09 Forester 5MT
'11 Outback 6MT

Default

anyone got problem like that?
peter
Bumble Bee 03 is offline   Reply With Quote
Old 01-27-2004, 01:28 AM   #5
subzero_Legacy_Gt
Scooby Specialist
 
Member#: 52185
Join Date: Jan 2004
Chapter/Region: VIC
Default

same thing happened to me..did u disable your daytime running lights? if u didn't thats why your ballast is not working...hid's have to run on full power not the power of daytime running lights...u have to get that ballast fixed or replaced
subzero_Legacy_Gt is offline   Reply With Quote
Old 01-27-2004, 06:51 AM   #6
Bumble Bee 03
Scooby Specialist
 
Member#: 25448
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: u know where i live...
Vehicle:
'09 Forester 5MT
'11 Outback 6MT

Default

yes I disable daytime running lights..... it was working for a month
I order new ballast, i just hope that this one will work for a longer time
Peter
Bumble Bee 03 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: OEM D2S 4300K v7 Projector HID bulbs, New H1 5000K McCulloch HID bulbs, CHEAP! Wrinkleboi Private 'For Sale' Classifieds 15 03-26-2006 03:10 AM
Bohmen vs. McCulloch HID kits Basshead Electrical & Lighting 23 06-09-2005 05:45 PM
ANY Member with McCulloch HID KIT? CVC THIS Mid Atlantic Impreza Club -- MAIC 0 03-15-2003 10:14 PM
Question: Those with JDM headlights and McCulloch HIDs...plug and play? BlueWRXagon Interior & Exterior Modification 9 08-28-2002 07:23 PM
New Discovery on McCulloch HID Daffy Duck Interior & Exterior Modification 13 08-08-2002 09:06 PM


All times are GMT -4. The time now is 12:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.