Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-21-2004, 10:00 PM   #1
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Have a Nice Day? Low fuel Pressure ej20g

Hey guys,

I just bought a impreza that has a ej20g installed. Fun car. Some drivability issues (idle, no top end: most likely due to bad fuel maps?)

Here is my problem. Usually my fuel pressure guage reads 25psi along with an audible fuel pump hum. I drive to work. Everything is fine. Then on my way home, i go to start it and the hum is very low. Almost nonexsitant and the pressure barely above 0psi. It starts with trouble and can idle for a few seconds. Then when I touch the throttle it dies.

I think its my fuel pump. I need to rectify it asap. Any help is appreciated deeply. I am going to pick up a fuel pump tomorrow if that is what it is.

Thanks.
* Registered users of the site do not see these ads.
joehack98 is offline   Reply With Quote
Old 01-21-2004, 11:16 PM   #2
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

I guess that is the place to start
my ej20G with a tiny tubo has plenty of top end ...hmm
Jaxx is offline   Reply With Quote
Old 01-21-2004, 11:23 PM   #3
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

This car is also running LINK engine manangement. and is set at 1.0 bar. I, personally only took it there once and was questioning the fuel to get there and tuning so I havent seens. Ive heard knock before and didnt experiance it in this instant.
joehack98 is offline   Reply With Quote
Old 01-22-2004, 12:57 AM   #4
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

Anyone else want to throw out an idea so I can check my options before i purchase and install the pump?


Thanks
joehack98 is offline   Reply With Quote
Old 01-22-2004, 03:56 AM   #5
Ver.III
Scooby Specialist
 
Member#: 1185
Join Date: Mar 2000
Location: North of the border
Vehicle:
I flap my gums
and now I'm a specialist

Default

Check the fuel filter ?

Where is the fuel pressure gauge sensor mounted ?
Ver.III is offline   Reply With Quote
Old 01-22-2004, 12:35 PM   #6
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

Also, Where is the fuel pump fuse and relay. I do still hear the fuel pump going on. I hear a clicking under the dash (top left). ! click then fuel pump stops.

Any ideas? Thanks

ps. sometimes my link system console acts up with funny characters. Only by turning it on and off a bunch of times does it go to the usual "test RPM." insite?


Thanks
joehack98 is offline   Reply With Quote
Old 01-23-2004, 11:52 PM   #7
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

How about some fuel pump removal tips?

Thanks.
joehack98 is offline   Reply With Quote
Old 01-24-2004, 01:27 AM   #8
DuoMaxwell
Scooby Specialist
 
Member#: 24565
Join Date: Sep 2002
Location: Misawa Japan
Vehicle:
2000 V6 STi RA #856
Blue

Default

Jaxx LOL man the no top end comment kills me. I have seen speeds of 250KM/H in my wrx with the stock tiny TD05 on it LOL!!!
DuoMaxwell is offline   Reply With Quote
Old 01-24-2004, 02:41 AM   #9
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

Yeah, at 1bar my car feels like it hits a brick wall at 6k... Hope the fuel pump is the trick..
joehack98 is offline   Reply With Quote
Old 01-25-2004, 01:37 AM   #10
99WRXEJ20
Scooby Specialist
 
Member#: 34545
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Worthington, Ohio
Vehicle:
1999 GC8
74f

Default

wonder what fuel pump your running and what one your going to buy?
99WRXEJ20 is offline   Reply With Quote
Old 01-25-2004, 02:16 AM   #11
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

bought a walbro.
joehack98 is offline   Reply With Quote
Old 01-25-2004, 09:41 PM   #12
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

Quote:
Originally posted by DuoMaxwell
Jaxx LOL man the no top end comment kills me. I have seen speeds of 250KM/H in my wrx with the stock tiny TD05 on it LOL!!!
no no i have a vf-10
your looking for a td05 for me remember...
Jaxx is offline   Reply With Quote
Old 01-26-2004, 04:26 AM   #13
joehack98
Scooby Newbie
 
Member#: 53243
Join Date: Jan 2004
Location: bay area
Default

fuel pump fixed it.. Next problem is cold start and holding idle on cold start.
joehack98 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low fuel pressure 02' wrx, thoughts? 240sxguy Service & Maintenance 9 03-08-2010 07:29 AM
Lean condition via low fuel pressure? BadTrip UTEC 18 11-06-2006 12:23 PM
low fuel pressure notgm Factory 2.0L Turbo Powertrain 5 01-20-2006 08:37 PM
Suddenly, Low Fuel Pressure at idle?? IowaRS Normally Aspirated with bolt-on Forced Induction Powertrain 7 01-02-2005 06:32 PM
Low Fuel Pressure, help! Diezel Factory 2.0L Turbo Powertrain 0 10-14-2004 03:32 PM


All times are GMT -4. The time now is 07:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.