Welcome to the North American Subaru Impreza Owners Club Friday April 29, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-25-2004, 10:44 PM   #1
Subi01
Scooby Newbie
 
Member#: 33489
Join Date: Feb 2003
Location: Omaha
Vehicle:
1995 Imp 2.2L Coupe
Sedona Red

Default O2 senser problem...any suggestions?

ello!

I have a 1995 Impreza 2.2L coupe, Sedona red. I bought the car used in 2002. Well, in July of 2003 I had a custom exhaust from a well-known muffler shop in Albuquerque, New Mexico (from where I am originally from) done on the car. It included a high flow cat from the manifold, a 2 and 1/4 wide pipe ending with a Dynomax muffler. No problems after it was installed, until...

About the middle of December 2003: it threw a check engine light. I had a dealership (out in Omaha, Nebraska, where I'm out here for college) pull the code off, and it said a deficiency in the O2 sensor. They cleared the code from the computer.

Last night it threw the same light, I got angry and just had Autozone pull the code off for free, and it was the SAME code.

Any suggestions on where I should go from here? Should I honestly replace the O2 sensor with one that can hanlde the difference from the change and, if so, where I go from there?

Thanks much!
* Registered users of the site do not see these ads.
Subi01 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-26-2004, 07:55 AM   #2
overdose
Scooby Specialist
 
Member#: 46399
Join Date: Oct 2003
Chapter/Region: MWSOC
Location: Grand Rapids, MI
Vehicle:
0000 Knows nothing,
about nothing.

Default

O2 sensors just go bad, replace it...

either get one OEM online from like www.subaruparts.com, pick a bosch universal up and splice it yourself... doesn't really matter, recommended replacement is 60k on o2 sensors

i just wait till they go out of spec
overdose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
06 STI BOOST Problem - Any Suggestions? QueensKid Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 32 01-04-2007 01:27 PM
Ant problem, any suggestions? xothermic Off-Topic 16 06-22-2005 11:18 AM
ECU problems, any suggestion?? ezaldere Electrical & Lighting 0 07-08-2004 07:47 PM
ECU problems, any suggestion ezaldere Service & Maintenance 8 06-30-2004 10:08 PM
Door light problem.. any suggestions? Herojin Electrical & Lighting 3 05-23-2003 05:19 PM

All times are GMT -4. The time now is 11:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.