Welcome to the North American Subaru Impreza Owners Club Saturday August 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-26-2004, 11:13 AM   #1
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default So No more Rotas breaking?

I dont recall reading about any more attacks breaking last season. Seems like it was just an isolated batch problem.

Has anyone heard of any other problems with attacks or subzeros?
* Registered users of the site do not see these ads.
Davenow is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-26-2004, 01:35 PM   #2
TheWRX
Scooby Specialist
 
Member#: 10279
Join Date: Sep 2001
Location: St. Louis, MO
Vehicle:
2005 Lotus Elise
Yellow, #94 SS

Default

There was a thread about a broken Subzero a week or two ago. Otherwise it has been very quiet. These really seem to be isolated incidents, considering how many of us are using Rota wheels. I had a close look at my Subzeros (manufactured in 2001) when I took them off for winter, and they're fine.
TheWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So. Fla: 17x7 Rota Downshifts, Bronze, no tires Machine Age Victim Wheels/Tires 12 05-13-2007 09:46 AM
Oh, no, say it ain't so. No more 04 STi's gdrew Mid Atlantic Impreza Club -- MAIC 19 04-19-2004 04:44 PM
Say it aint so! no more pr0n! HighWayDrifter Off-Topic 27 04-16-2004 03:26 PM
What did I break? No more side marker or taillights JimDab Electrical & Lighting 3 03-08-2003 09:20 AM
so jamba juice is no more jmott Texas Impreza Club Forum -- TXIC 34 04-16-2002 03:35 PM


All times are GMT -4. The time now is 05:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.