Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-24-2004, 07:19 PM   #1
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Question help! my piaa xt pro 80s

i just installed them last week.
they were workin for a couple days, but now they wont turn on!
i installed them just as instructed on scoobymods.com or whatever. wired them to my stock switch. but now they only work sometimes or dont. i checked the fuse, but that is ok.
what's wrong!!!!!!!!!! could an exposed ground wire affect it?
i dunno, i just dont want to take off the damn bumper again just to look. crap!
* Registered users of the site do not see these ads.
kAn9ArOo is offline   Reply With Quote
Old 01-24-2004, 08:16 PM   #2
BlkTS02
Scooby Specialist
 
Member#: 50142
Join Date: Dec 2003
Chapter/Region: South East
Location: West TN
Vehicle:
2002 2.5TS
MBP

Default

sounds like a loose connection or wire somewheres. When you press the button to turn them on, do you hear the click from the relay?
BlkTS02 is offline   Reply With Quote
Old 01-24-2004, 09:45 PM   #3
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Default

no i dont hear a click. but i didn't hear a click before either...???hmmmm
kAn9ArOo is offline   Reply With Quote
Old 01-25-2004, 01:10 AM   #4
esteve
Scooby Specialist
 
Member#: 28716
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2006 STI

Default

Yeah, seems like a loose connection somewhere. You could shake the wires wherever there's a connection and see if the lights flicker on and off.
esteve is online now   Reply With Quote
Old 01-26-2004, 01:57 AM   #5
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Question

i checked the wires where i could. doesn't look like anything is wrong. i do hear a click from the relay, but the lights dont turn on! could i have blown them out already?!?! anyone, help!
kAn9ArOo is offline   Reply With Quote
Old 01-26-2004, 02:29 PM   #6
vtwrxsti
Scooby Newbie
 
Member#: 31767
Join Date: Jan 2003
Location: burlington, vt
Default

Time to break out the test light... check the wiring at the relay, which I expect is more accessible than the lights. As for getting to the wiring, I found going from the front wheel well - removing the plastic anchors for the inner splash guard - allows access to the back of the fog lights quickest.

Check for power at the switch, etc.
vtwrxsti is offline   Reply With Quote
Old 01-27-2004, 02:36 AM   #7
kAn9ArOo
Scooby Newbie
 
Member#: 2294
Join Date: Sep 2000
Default ahh

yeah this sucks! heh
kAn9ArOo is offline   Reply With Quote
Old 01-27-2004, 01:06 PM   #8
ursine
*** Banned ***
 
Member#: 51771
Join Date: Jan 2004
Location: San Diego
Vehicle:
2000 Impreza GC6 SRP
1980 G2 Celica Rally Taxi

Default

I have a set of these lights and I was considering installing them on my RS. How would I go about doing it, do I need to get a custom bracket or something or does someone make one?

-Branden
ursine is offline   Reply With Quote
Old 01-27-2004, 01:30 PM   #9
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

Quote:
Originally posted by ursine
I have a set of these lights and I was considering installing them on my RS. How would I go about doing it, do I need to get a custom bracket or something or does someone make one?

-Branden
www.kartboy.com - kartboy bracket.... www.scoobymods.com for instructions.
ATX25RS is offline   Reply With Quote
Old 01-27-2004, 07:23 PM   #10
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

Check the bulbs. I somehow managed to blow both bulbs in my Cibie's one day...
rhdude is offline   Reply With Quote
Old 01-27-2004, 11:12 PM   #11
BlkTS02
Scooby Specialist
 
Member#: 50142
Join Date: Dec 2003
Chapter/Region: South East
Location: West TN
Vehicle:
2002 2.5TS
MBP

Default

There's a warning telling you not to turn the lights on and off rapidly, as it'll drastically shorten the bulb life.

I've had mine in for close to two years, no problems. Well apart from almost blinding myself from the light reflecting off of roadside signs
BlkTS02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PIAA 80 Pro XT Help HighRevimpreza Electrical & Lighting 4 09-23-2009 06:16 PM
PIAA 80 Pro XT Help HighRevimpreza Interior & Exterior Modification 2 09-14-2009 02:48 AM
help! piaa xt pro 80 kAn9ArOo Electrical & Lighting 3 03-22-2004 09:29 PM
anyone have piaa xt 80 pros? kAn9ArOo Electrical & Lighting 4 01-22-2004 10:26 AM
piaa 80 pro xt lights dyswtric27 Private 'Wanted' Classifieds 0 07-24-2003 10:15 AM


All times are GMT -4. The time now is 03:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.