Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-30-2004, 11:04 AM   #1
Hummer
Scooby Specialist
 
Member#: 31892
Join Date: Jan 2003
Location: KC
Vehicle:
2004 STi
Silver

Default Xede 93-94 stage one MAP in the STi and dyno

This is a long story so bear with me. I woke up at 5 am and left the house about 6:00 am for St. Louis. 10:00 am and I am at Axis in St. Louis. FIRST things....Ron busted his butt all day on my car and he did a great job. I highly recommend them. Now back to the story. Ron pulled my IC, Intake, and turbo. He then ported the waste gate on the turbo. Next was pulling my egt probe from the down pipe and putting it in the manifold. After that he hooked up my turbo gauge and corrected a miswiring of my gauges which was killing my battery. He then reinstalled the turbo and downpipe. He got all of this done in less than 3 hours and then we had a delightful lunch.

2:00pm Alrighty then....now is where the REAL fun started. Ron pulls out the XEDE and the color code instructions from Vishnu for the pin outs were wrong. Vishnu would not answer the phone today so we{Ron} were on our own. He got them all wired correctly the first time. The next step was was to fire it up. Vishnu did not load the STi stage 1 maps{or any maps for that matter}. Every map was zeros. Ok...no problem...Mike and I go to his place for internet access and he downloads the sti maps from the Vishnu site and burns them to disk. We then go back to the shop.

4:00 pm Got the maps, put them in the Xede. The car is running......good sign. Time to head to Ron's other place for the dyno.

4:30 pm Oh look outside...it is so pretty....it's snowing! This is getting exciting with me, the STi and the stock tires. I don't know where I am and it's snowing....Yea!

5:30 ish {losing temporal cohesion} OK...On the dyno we go and I have 200 WHP. SWEET! Ron scans the info and I am running 9 PSI max boost. Hmmmm.............Vishnu is still not answering calls.........Ron determines that the STi stage one 93-94 boost map is horribly wrong. Ron then had to fix it.

7:30 ish 15 pulls on the dyno. The car is tuned and the throttle body is hot.. Nobody wants to wait around an hour to cool and do it again.

8:00 ish leaving Illinois and heading home {the roads were pretty clear}.

11:59 Home - 3 beers, 30 emails, and off to bed.


Here is the dyno info......Dyno Dynamics Dynamometer
Max WHP was 257
Max Torque was 280
This was a 3rd gear pull running 93 reformulated winter gas.

The dyno is here. http://home.kc.rr.com/cerberus/xede_and_dyno.htm

The max boost on the final dyno was 15 psi. It might need more tweaking or it might be the heat. I should know soon. I didn't push it on the way home because of the weather and I was tired.

Edit: I took the car out this morning and I hit 16.5 PSI in 3rd. There is a noticable difference with the XEDE in power and torque.

Thanks again Ron and Mike! They know subies!
* Registered users of the site do not see these ads.

Last edited by Hummer; 02-01-2004 at 10:45 AM.
Hummer is offline   Reply With Quote
Old 01-30-2004, 12:02 PM   #2
jblaine
Scooby Guru
 
Member#: 8512
Join Date: Jul 2001
Chapter/Region: South East
Location: St. Pete, FL
Vehicle:
2002 WRX chassis...
stage-infinity.com

Default

So this is with a turboback + Xede as the only performance mods?
jblaine is offline   Reply With Quote
Old 01-30-2004, 02:23 PM   #3
Hummer
Scooby Specialist
 
Member#: 31892
Join Date: Jan 2003
Location: KC
Vehicle:
2004 STi
Silver

Default

TXS TBE+XEDE+Gruppe S headers. The headers add a lot of torque.
Hummer is offline   Reply With Quote
Old 01-30-2004, 09:38 PM   #4
bezerk
Scooby Specialist
 
Member#: 44809
Join Date: Oct 2003
Chapter/Region: W. Canada
Location: Northern BC
Vehicle:
2008 BMW M3
SATURDAY!!!!!!!!!!!!!!!

Default

very nice numbers...thanks for the info
bezerk is offline   Reply With Quote
Old 01-30-2004, 11:54 PM   #5
MJU1983
Scooby Specialist
 
Member#: 14364
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: Saint Louis, MO
Vehicle:
2003 WRX, '06 Armada
05 Vette & 05 STi (sold)

Default

Sounds good stuart. At least its making a couple more pounds of boost, that should make the thing pull nice and hard.

-Mike
www.axispowerracing.net
MJU1983 is offline   Reply With Quote
Old 01-31-2004, 02:01 AM   #6
thechoochman28
Scooby Specialist
 
Member#: 42900
Join Date: Sep 2003
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2004 WRX

Default

Man i don't miss IL winters at all.
thechoochman28 is offline   Reply With Quote
Old 01-31-2004, 04:01 AM   #7
speed_freak27
Scooby Specialist
 
Member#: 30798
Join Date: Dec 2002
Location: kansas city ks
Vehicle:
2001 RS-T Hybrid
2.5>2.2T>257>2.35S

Default

I'm calling BS 3 hours to get home and you didn't push it. Yeah right I know as well as a few other locals how you drive. I can't wait for the track to open up so I can drive your car again.
speed_freak27 is offline   Reply With Quote
Old 02-01-2004, 02:47 AM   #8
STi City
Scooby Newbie
 
Member#: 43327
Join Date: Sep 2003
Default

so how did they fix the boost map? what kind of numbers are on your boost map?
STi City is offline   Reply With Quote
Old 02-01-2004, 10:43 AM   #9
Hummer
Scooby Specialist
 
Member#: 31892
Join Date: Jan 2003
Location: KC
Vehicle:
2004 STi
Silver

Default

Quote:
Originally posted by STi City
so how did they fix the boost map? what kind of numbers are on your boost map?
PM sent.
Hummer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Cobb Accessport for 08 sti w/ perrin stage one map tlewis81 NESIC Private Classifieds 2 06-20-2009 07:57 PM
Differences between Cobb Stage 2 maps for 91, 91 and ACN 93 2slow AccessPort 0 02-12-2009 06:04 PM
stage one map thiefdevious Open Source Reflashes 1 10-28-2008 01:09 AM
Is the 2.5 Turbo the same in the STI and Forrester? tchprivat Factory 2.5L Turbo Powertrain 10 09-09-2004 06:28 PM
Racing Seat Installation in the STI and Review Triple S STi Forum Archive 15 09-01-2003 10:19 PM


All times are GMT -4. The time now is 08:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.