Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-31-2004, 04:35 PM   #1
tobin73
Scooby Newbie
 
Member#: 28673
Join Date: Nov 2002
Location: Auburn Hills, MI
Vehicle:
1997 Impreza Outback
Acadia Green Metallic

Default Starter grinding after start - replace?

My starter grinds for 2 seconds after startup. Is there any way to fix this without buying a new starter? The battery connectors are clean and the battery shows 12 volts and 14 volts when running so it's good.
* Registered users of the site do not see these ads.
tobin73 is offline   Reply With Quote
Old 01-31-2004, 07:12 PM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

sounds like the starter is hanging up and staying engaged, so reall way around it than replacing or rebuilding the starter, if that is the case.

Jay
munkis is offline   Reply With Quote
Old 01-31-2004, 11:12 PM   #3
PRIOR
Scooby Newbie
 
Member#: 27524
Join Date: Oct 2002
Location: Las Vegas, NV
Vehicle:
95 Impreza L awd
2.5 swap & only 2400lbs

Default

i had this same exact problem for the last year in my car, and just 2 weeks ago was when the starter went out... i just replaced mine since i got it for pretty much nothing.

let me tell you though, jump starting the car with the clutch for a week while the starter was bad was not fun...
PRIOR is offline   Reply With Quote
Old 02-01-2004, 03:24 PM   #4
supermoose
Visiting NASIOC Timeout
 
Member#: 9093
Join Date: Aug 2001
Location: SF
Vehicle:
1995 RHD STi RA Ver2
swap starr

Default

you can get a starter for $45 bux. j-yard take you 1/2 hour to swap out. a new reman one is only $100 or so. if you need help, im local and can teach you how to do it. im introy

h
supermoose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter grinds after start rick-l Factory 2.0L Turbo Powertrain 15 01-23-2010 02:58 PM
Car won't start after engine replacement... rickeolis AccessPort 4 08-07-2007 10:47 PM
Starter grinding after start - replace? tobin73 Service & Maintenance 1 01-31-2004 05:25 PM


All times are GMT -4. The time now is 06:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.