Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-01-2004, 12:44 AM   #1
SmoknWRX
Scooby Newbie
 
Member#: 44983
Join Date: Oct 2003
Location: Va.Beach/school at Radford
Vehicle:
2003 impreza wrx
aspen

Unhappy Knock At Low Boost...help

OKAY GUYS, HERE ARE MODS.....INTAKE,UP PIPE, TURBOBACK EXHAUST WITH NO CATS, AND UTEC STG2 MAP.

HERES THE PROBLEMS, 2 WERE RESOLVED TONIGHT

1. INCONSISTENT IDLE
2. between 4-5k rpms and 20-40% throttle the car begins to sputter and some times results in the car to jump back and forth. after logging it i noticed the injector duty was jumping from 20-40% to 70% and back down in the matter of split seconds.

THESE PROBLEMS FIXED BY THE REMOVAL OF MY MAF SENSOR

3. heres the big problem.......its really cold outside and yet i cant run more than 14 psi without knock. turbo xs said that with my mods i should be running 16.5-17 psi. my friend is running the exact same setup and is peaking at 18.5psi. what the heck is going on??
right now ive turned the boost down to 12 psi and still see knock after full aceleration thru 1st and 2nd gear and let off the throttle right after my shift into 3rd. so its still knocking right as i back off the throttle in the begining of 3rd.

i have not altered the fuel/timing map since i uploaded it from TXS.

and why cant i get full boost in all gears?? would adding a MBC that totally bypasses the use of the stock solenoid help me out?

if your still reading this thank you for staying with me through all this typing, hahaha. if u can help me out any itd be awesome, thanks!!!!
* Registered users of the site do not see these ads.
SmoknWRX is offline   Reply With Quote
Old 02-01-2004, 02:20 AM   #2
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

Did you tell txs that you took out your maf? I don't think you can just remove the maf, run the car and expect it to run normally. The ecu determines the fueling of the car by the maf reading. That's why you were having the fueling problems b4, and probably why you're having problems now. It would probably be a good idea to put the stock intake back on, the maf back in, reset the ecu, and see what happens. That's just my opinion though.

peace
hippy is offline   Reply With Quote
Old 02-01-2004, 02:40 PM   #3
SmoknWRX
Scooby Newbie
 
Member#: 44983
Join Date: Oct 2003
Location: Va.Beach/school at Radford
Vehicle:
2003 impreza wrx
aspen

Default

i have been informed that with a utec a maf sensor is unneccesary. the car now runs better than before but still got knock at boost higher than stock psi
SmoknWRX is offline   Reply With Quote
Old 02-01-2004, 06:12 PM   #4
chuglobal
Scooby Specialist
 
Member#: 10041
Join Date: Sep 2001
Location: Marietta, Ga.
Vehicle:
2015 WRX Limited CVT
ISM

Default Yo

1. Put the MAF sensor back.

2. There is a "huge" difference in what the Stage 2 map "wants" to run for timing thus will knock when it's cold. I think I've just finished my Stage 2 map tuning in cold weather as of a few days ago. Do a run w/ the MAF sensor back on, in 3rd WOT, and post log 1.
chuglobal is offline   Reply With Quote
Old 02-01-2004, 06:37 PM   #5
wrx plus
Scooby Specialist
 
Member#: 42253
Join Date: Aug 2003
Location: Hampton, Va.
Vehicle:
2003 RWD WRX
Alcohol injected, WRB

Default

Who ever told you to take off the MAF is an Idiot. If you need proof call txs in the AM, since you're really not listening to the people here.
wrx plus is offline   Reply With Quote
Old 02-01-2004, 07:25 PM   #6
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

Quote:
Who ever told you to take off the MAF is an Idiot.
I wouldn't say that, but from what I know(and I run a utec also), you need the maf for normal fueling. You might want to put the maf back in and the stock intake back on. You might also want to stay away from making modifications if you don't know what they will do to your car(utec manual cover page).....

peace
hippy is offline   Reply With Quote
Old 02-01-2004, 09:21 PM   #7
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

You must put your MAF sensor back in. The UTEC 3.1 is boost based after 60% (default) tps, but your stock ECU is MAF based.

Your UTEC offsets the ECU fueling so you always need the MAF sensor.

The reason that your #1 and #2 issues resolved is that you forced the ecu into panic mode so it's running rich. Would be my guess anyway. Please put your MAF sensor back in.

Knock is usually down to lean fueling, too much boost or too much timing advance. Sounds like you have a mixture of these.

If you want to run higher boost you will have to check your fueling. You also need to lower your timing numbers.

But to make things easy put your MAF sensor back in and the run some UTEC logs and post those so we can analyze them.

Are you running the Octane challenged map from TurboXS, if so you should be.
mick_the_ginge is offline   Reply With Quote
Old 02-02-2004, 07:59 PM   #8
wrx plus
Scooby Specialist
 
Member#: 42253
Join Date: Aug 2003
Location: Hampton, Va.
Vehicle:
2003 RWD WRX
Alcohol injected, WRB

Default

Listen to him^^^^^^ he's the smart one.
wrx plus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
knock at low load? austria impreza Engine Management & Tuning 9 10-10-2009 02:25 PM
Engine knock at low RPM's rek888v2 Factory 2.5L Turbo Powertrain 12 01-02-2006 10:30 AM
Steering column knock at low speeds Jitenshakun Canada Region Forum 10 01-14-2005 10:03 AM
Knock at low rpm and throttle PharmCo Factory 2.0L Turbo Powertrain 4 02-02-2004 10:28 PM
Knock At Low Boost....help SmoknWRX Factory 2.0L Turbo Powertrain 9 02-01-2004 07:23 PM


All times are GMT -4. The time now is 05:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.