Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-01-2004, 10:52 PM   #1
Kyguy
Scooby Newbie
 
Member#: 38705
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
'95 GM2 Rally Car
& '08 WRX

Question noise when going over bumps!

When I go over bumps, the front right tire makes some noise, maybe I can even record it on my digi cam, but basically it just sounds like wreeewraah. (hah!) Any suggestions?
I've jacked up the car, looked under it but I don't see anything bad. I went over a curb in the snow () but that was a while back.

Suggestions? Everything is stock and it's only when I go over speed bumps.
* Registered users of the site do not see these ads.
Kyguy is offline   Reply With Quote
Old 02-02-2004, 01:52 AM   #2
StarDogChampion
Scooby Specialist
 
Member#: 10276
Join Date: Sep 2001
Vehicle:
2001 Impreza RS
2002 WRX, 2012 535i

Default

My car does the same thing, but mine happened after I installed a 22mm swaybar up front. In my case, I think its the sway bar mounts. I was told to use graphite grease or white lithium grease and even wrap the bar with teflon tape where it meets the mounts. Possibly the same in your case even though you are still stock up there.
StarDogChampion is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Noise when going over bumps! ( no clunk) SubbyPAT Brakes, Steering & Suspension 5 03-31-2007 11:04 AM
Bad clunking noise from front pass side when going over bumps? (05 STi) Optimus Prime Brakes, Steering & Suspension 16 06-24-2006 10:18 PM
rattling or clunk noise when going over bumps hilfiger4you Service & Maintenance 1 08-07-2005 11:06 AM
Noise when going over speed bumps and up/down driveways Evaider Brakes, Steering & Suspension 10 05-23-2002 03:14 AM


All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.