Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-02-2004, 08:10 AM   #1
runner19
Scooby Newbie
 
Member#: 39562
Join Date: Jul 2003
Chapter/Region: MAIC
Vehicle:
My02 WRX Sedan 5MT
WR blue

Unhappy P0420 and fuel consumption

I have a MY02 WRX with a AF531v3 map switch rom(ecutek).

Ambient Temp 87 F

My cars fuel consumption has increased by 80% recently. My car has a SPT bosal exhaust with a gutted uppipe(full decat). It is throwing a P0420 cel. The car runs fine other than the increase in fuel consumption

I have had it checked for boost/exhaust leaks and there were none.

1. Can the P0420 code be causing this increase in fuel?
2. Is the Ecutek temp compensation causing the increase in fuel consumption becasue of high ambient temps?
* Registered users of the site do not see these ads.
runner19 is offline   Reply With Quote
Old 02-02-2004, 09:05 AM   #2
mouserWRX
Scooby Specialist
 
Member#: 48960
Join Date: Nov 2003
Location: Austin
Vehicle:
2006 TL
Anthracite

Default

I remember hearing that your car runs in some kind of "safe mode" when you get a CEL thrown, and so yeah I believe it's running rich. I threw a P0420 code for about a couple of days however, I didn't really notice THAT big of a difference. I'm not sure about #2, but I doubt #1 would cause an 80% increase in fuel consumption.
mouserWRX is offline   Reply With Quote
Old 02-02-2004, 11:29 AM   #3
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

The P0420 cat code will not effect which ecu map you are running. Other codes can, not this one.

Of course your ECU could have seen enough knock that your ignition advance multiplier has dropped below 8 and you are running the safe and rich map.

Do you have delta dash to check the IAM?
mick_the_ginge is offline   Reply With Quote
Old 02-02-2004, 06:52 PM   #4
jland67
Scooby Specialist
 
Member#: 14427
Join Date: Jan 2002
Chapter/Region: South East
Location: Cary NC
Vehicle:
2002 09 Mazdaspeed 3
Grey

Default

I ran with a P0420 for months on end with no problems.


Jeremy
jland67 is offline   Reply With Quote
Old 02-04-2004, 02:55 PM   #5
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Stuck/sticky injector....???
Uncle Scotty is offline   Reply With Quote
Old 02-04-2004, 04:27 PM   #6
motoxphil
Scooby Newbie
 
Member#: 5094
Join Date: Mar 2001
Location: Gaithersburg, MD, usa
Vehicle:
2002
11.96, 1.64, 115mph!

Default

Could it be that you are WOT 80% more than before

Things like this tend to happen when new performance parts are installed

Phil
motoxphil is offline   Reply With Quote
Old 02-04-2004, 09:40 PM   #7
Rally Performance
Vendor
 
Member#: 16588
Join Date: Mar 2002
Location: www.rallyperformance.com
Default Agreed

I agree with Mick. Try an ECU reset, and see if it clears up your problem... if you have Delta Dash, you can download the latest version at www.ecutek.com and can see the advance multiplier. The P0420 code won't cause the car to switch to the hi detonation fuel map, but low advance multipliers might.

You may be having another problem, but see if a reset clears it up.

Regards,
Ken
Rally Performance
Rally Performance is offline   Reply With Quote
Old 02-15-2004, 07:56 PM   #8
WiredWRX
Scooby Specialist
 
Member#: 20768
Join Date: Jul 2002
Location: Los Angeles, CA
Vehicle:
2009 IS-F
Black

Default

I noticed the same thing when I threw the PO420. Never had the numbers to prove it, but I noticed that as soon as I threw the code, my gas mileage would suck.

I just figured that the ECU was trying to compensate for the cat innefficiency by running the car rich. Why, I don't know, cause I would think that running rich would have the opposite effect, but, my gas mileage deffinitely sucked when I had the cel.

Got the PDE DP, no more CEL, no more crappy gas mileage.

Problem solved.

Michael
WiredWRX is offline   Reply With Quote
Old 02-17-2004, 05:56 PM   #9
marto
Scooby Newbie
 
Member#: 51538
Join Date: Dec 2003
Location: philadelphia
Vehicle:
1994 impreza
red

Lightbulb

I have high gas consuption too.
1.8 impreza 200 miles with a full tank
please help?
already change air filter and actually the old one had a grissy spot in the middle.
02 sensor maybe but how do I check it?


I like my suby I drive it hard even when it is tainy.
new with subys
marto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
And you thought your fuel consumption is bad.. xenonk Mid Atlantic Impreza Club -- MAIC 3 12-16-2005 10:17 AM
FYI: Fuel consumption calculator Ken Newbies & FAQs 0 01-26-2001 02:40 PM
Excessive fuel consumption Mr.Sniggs Legacy Forum 6 12-14-2000 10:48 AM


All times are GMT -4. The time now is 07:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.