Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-03-2004, 06:09 PM   #1
Steroid500
Scooby Newbie
 
Member#: 49550
Join Date: Nov 2003
Location: LaGrangville, New York
Vehicle:
2000 Impreza 2.5 RS
Blue Ridge Pearl

Default Strange electric/lighting problem

For some reason, my passenger side corner light keeps goin out, this is the 2nd time its happend, ive had the car for 9 months now, i origanally replaced the bulbs back in july with 194 led bulbs, the passenger side lasted till about november, the light completly blew out, i tried it on the other light, it was dead, replaced the light, now it just died again, im still useing the original led i put in in july on the drivers side, anyone have any ideas what could be causeing? it must be something to do with the circuit, but is there a quick fix for it? i want to try to avoid a shop at all costs if i have to, ive had electrical work done in another car & it wasnt fun, ended costing me a truckload for something i couldve fixed myself. please help
* Registered users of the site do not see these ads.
Steroid500 is offline   Reply With Quote
Old 02-03-2004, 06:33 PM   #2
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

weird!
There's not any water trapped in there I guess?
1 Lucky Texan is offline   Reply With Quote
Old 02-03-2004, 08:10 PM   #3
Steroid500
Scooby Newbie
 
Member#: 49550
Join Date: Nov 2003
Location: LaGrangville, New York
Vehicle:
2000 Impreza 2.5 RS
Blue Ridge Pearl

Default

thats a good question, we've been getting pounded with snow & such the past couple of weeks, it might have snuck in somehow, ill have to check if we ever get a day above freezing, it gets real hard to take the light out without breaking off that screw tab off when its cold, i know that all to well

I dont see how it could get in there though

Last edited by Steroid500; 02-03-2004 at 09:02 PM.
Steroid500 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange rear light problem...help MER Electrical & Lighting 5 04-09-2012 10:30 PM
Strange electrical problem - Please help if you can Rice & Gravy Car Audio, Video & Security 12 04-01-2006 12:48 AM
strange electrical problems adj789 Electrical & Lighting 0 03-01-2004 11:44 AM
Strange electrical problem oldleg Service & Maintenance 1 05-21-2002 10:02 AM


All times are GMT -4. The time now is 06:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.