Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-12-2004, 12:49 PM   #1
Tobey
Scooby Specialist
 
Member#: 21400
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2015 WRX Limited
ISM

Default question about bad egt sensor, the egt fix etc

so my egt sensor went bad and i left it in there, did the resistor trick and my cel is gone.

now i got to thinking, the ecu is now seeing the same reading from that egt sensor all the time now right? which means my car is convinced that it only needs to give me X amount of fuel?

before i could never get my car above 1500f on my egt gauge (pass side manifold) but now i wonder if it would be easier to melt stuff? this is my assumption only, can anyone verify this?

anyone know the approximate price of a new egt sensor? i think it might be worthwhile to replace it!!
* Registered users of the site do not see these ads.
Tobey is offline   Reply With Quote
Old 02-12-2004, 01:00 PM   #2
mexicanpizza
Scooby Specialist
 
Member#: 16779
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2008 God's Gift to
Turbo Wagons (MS3)

Default

EGT sensor != fueling control. It's just to tell the engine if that uppipe cat is melting/burning. You were probably thinking of the front 02 sensor.
mexicanpizza is offline   Reply With Quote
Old 02-12-2004, 02:40 PM   #3
Tobey
Scooby Specialist
 
Member#: 21400
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2015 WRX Limited
ISM

Default

Quote:
Originally posted by mexicanpizza
EGT sensor != fueling control. It's just to tell the engine if that uppipe cat is melting/burning. You were probably thinking of the front 02 sensor.

wouldn't the egt have to control some aspect of fueling? think about it, if your egt's are high the ecu has to see that, so it compensates...

this is my theory only, just not sure if i am anywhere close? i started throwing it around in my head and got to wondering...
Tobey is offline   Reply With Quote
Old 02-12-2004, 02:43 PM   #4
mexicanpizza
Scooby Specialist
 
Member#: 16779
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2008 God's Gift to
Turbo Wagons (MS3)

Default

Welp, read up more around here...it's pretty well documented that the EGT sensor is ONLY there for determining the combustion status of the uppipe cat.

I would say about 1/2-2/3'rd's of the people with WRX's and catless uppipes run the resistor mod.
mexicanpizza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uppipe EGT sensor removal. CEL fix? Gro Harlem Factory 2.0L Turbo Powertrain 6 01-21-2009 01:53 PM
Questions about toe and camber, need to fix bigtime problem in my front end. muckchiller Brakes, Steering & Suspension 5 12-30-2007 07:15 PM
Question about rear O2 sensor Speedy02wrx Factory 2.0L Turbo Powertrain 1 05-29-2003 06:01 AM
Questions about stock shock sensor on 2000 2.5 RS slim speedy Car Audio, Video & Security 1 03-05-2003 11:28 AM
Question about air/fuel sensors Stranger Normally Aspirated Powertrain 1 12-03-2002 09:33 PM


All times are GMT -4. The time now is 02:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.