Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-14-2004, 11:31 PM   #1
pkirby11
Scooby Newbie
 
Member#: 41732
Join Date: Aug 2003
Default Alternator Question

Okay so I have a question as to wether this is normal. When I am driving at night, I'm sure it happens in the daytime just have no way of telling as much because the lights are not on, and I have the stero running when ever I turn on the rear defrost or the fron defrost or both for that matter my power seems to dip unless I am driving. When this happens like at a stop light and I am idleing you can see the dash dim, the outside headlights dim quite a bit to. Now my fathers new Ford Minivan with a ton of electrical featuers including heated seats won't dim so I found this kind a of odd. Maybe someone could shed some light on the matter and if anyone thinks this is a little odd how should I go about getting it checked. I already talked to the dealer and he thought that much of a power drain was normal. My car is a 2003 WRX still under warranty and no modifications. Could be paranoid but I just wanted to get someones opinion other than the dealers. Thanks
* Registered users of the site do not see these ads.
pkirby11 is offline   Reply With Quote
Old 02-15-2004, 02:37 AM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Clean your battery terminals and/or put a good battery in your car. The 'grounding mod'(search) may help too.
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trunk & Alternator question wrxtreme227 Newbies & FAQs 5 10-22-2004 02:22 PM
Alternator Question urabus97 Legacy Forum 4 04-29-2004 04:39 PM
Power/Alternator Questions!!! WhyGog Car Audio, Video & Security 12 02-03-2004 01:00 AM
alternator question crrii Normally Aspirated Powertrain 3 07-20-2001 02:36 AM


All times are GMT -4. The time now is 12:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.