Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-16-2004, 02:55 AM   #1
eightballrj
Scooby Specialist
 
Member#: 18520
Join Date: May 2002
Chapter/Region: South East
Location: MS
Vehicle:
2005 L GT Limited
Black

Default Who has been tuned @ Axis by Ron???

I am anxious to see people's reactions and see how you like your tune from them. I have heard that Ron is an awesome tuner... I am going up there in a few weeks to get tuned. So, thats why I am wondering.

Thanks!!!
Richard
* Registered users of the site do not see these ads.
eightballrj is offline   Reply With Quote
Old 02-19-2004, 06:51 PM   #2
Julio
Scooby Specialist
 
Member#: 6363
Join Date: May 2001
Location: Gossip Island
Vehicle:
10 Sec. Club
Element - Crawford

Default

Well.. I know he is awesome... Let me know how your car runs after it is tuned.
Julio is offline   Reply With Quote
Old 02-19-2004, 08:10 PM   #3
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

he built my engine and i love it!!!

ej25 block
pauter rods
CP pistons
arp head studs
darton sleeves
cometic head geskets
dual valve springs
titanium retainers

ect ect...

i am using a garrett T62-1 turbo and UTEC engine management. i love the setup, rons motor has absolutely no (loud) rod knock when i start it up cold and none when im warm. it doddles along perfectly at like 1.5-2k RPMs and revs nicely and cleanly up high.

I would use ron again, and would totally let him build my motor again and or tune my car. he makes some big power setups!

Jared
jared nelson is offline   Reply With Quote
Old 02-20-2004, 05:01 PM   #4
Julio
Scooby Specialist
 
Member#: 6363
Join Date: May 2001
Location: Gossip Island
Vehicle:
10 Sec. Club
Element - Crawford

Default

Jared: Nice setup. How do you like it? Have you dyno it yet? Have you taken it to the drag strip? Any numbers you can provide?
Julio is offline   Reply With Quote
Old 02-20-2004, 06:40 PM   #5
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

i have not taken it to the dyno but i have taken it to the strip in vegas twice both times without luck because i couuld not run the Fing thing due to issues each time. so... ill have it taken to a track soon and ill let you know how it does. the thing is that the ****er has a 3k stall on the converter and my honkin ass T62-1 only makes about 2 lbs boost at that rpm. so my launches are prolly like 2.2-3 sec 60 foot launches. haha, im switching to a smaller a/r turbine side soon though.

oh and in my previous post i didnt mean rod knock i meant piston slap.
jared nelson is offline   Reply With Quote
Old 02-20-2004, 07:02 PM   #6
Julio
Scooby Specialist
 
Member#: 6363
Join Date: May 2001
Location: Gossip Island
Vehicle:
10 Sec. Club
Element - Crawford

Default

Good luck - What times do you expect?

Yes, we knew you meant piston slap as for souding like a Mack truck
Julio is offline   Reply With Quote
Old 02-21-2004, 06:05 AM   #7
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

when i upgrade the tranny and run the boost i want to run ill be in the low 11s i think. this car ran 11.8 at 118 before on the stock block and stock internals with a VF22 and a 150 shot, till the prev owner blew his motor so ill hope to be lower than that for sure. well to be honest myy goal is to compete with like ESX and some of the other really fast WRXs out there, but thats not what im claiming ill run right when i hit the track. that will be along time down the road...
jared nelson is offline   Reply With Quote
Old 02-21-2004, 07:28 AM   #8
Julio
Scooby Specialist
 
Member#: 6363
Join Date: May 2001
Location: Gossip Island
Vehicle:
10 Sec. Club
Element - Crawford

Default

Great! - Good luck in your quest. BTW - You will be using an auto tranny right?
Julio is offline   Reply With Quote
Old 02-21-2004, 01:24 PM   #9
eightballrj
Scooby Specialist
 
Member#: 18520
Join Date: May 2002
Chapter/Region: South East
Location: MS
Vehicle:
2005 L GT Limited
Black

Default

Hey Jared,
What cams are you running with your setup?? Or did I miss you saying that? Ahh, well I got my motor back yesterday and I am in the process of putting in the fuel system and re hooking up all the vacuum lines. Hopefully I will be able to get tuned this weekend or the next... I'll keep you guys posted.

Richard
eightballrj is offline   Reply With Quote
Old 02-21-2004, 02:50 PM   #10
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

oh yeah my cams are stock but ill be putting in jun cams after the tranny build and raising the rev limit to liike 9500. i allready have the dual valve springs, and titanium retainers, ported heads, and now i just need to get bucketless shims, and cams and have clark reflash the ECU or go standalone and reset the redline.
jared nelson is offline   Reply With Quote
Old 02-22-2004, 05:45 PM   #11
suberboy
Scooby Specialist
 
Member#: 1531
Join Date: May 2000
Chapter/Region: RMIC
Location: Salt Lake City, UT
Vehicle:
2008 GRB
Red

Default

Jared,
glad to hear the car is running well.
i sure hope you don't have rod knock warm or cold... it is piston slap that you might hear when you start the car.
rod knock means a bearing or bearings have gone bad and if that was the case you would need to take the motor back out and replace the bearings.

-noah
suberboy is offline   Reply With Quote
Old 02-22-2004, 09:27 PM   #12
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

i know i corrected myself allready on that, dont know if you read the whole thread or not. thanks for the congrats on getting it running.
jared nelson is offline   Reply With Quote
Old 02-22-2004, 10:43 PM   #13
suberboy
Scooby Specialist
 
Member#: 1531
Join Date: May 2000
Chapter/Region: RMIC
Location: Salt Lake City, UT
Vehicle:
2008 GRB
Red

Default

i thought i had read the whole post. duh my bad.
suberboy is offline   Reply With Quote
Old 02-23-2004, 12:36 AM   #14
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

so we did some street racing today, I was turning like 107-110 MPH by the finish and its like 1100 feet instead of 1320. Im thinking that the power is pretty healthy at 18 PSI boost, because my car seriously cannot cut faster than a mid 2 second 60 foots with the poor launch spool im getting. I dont get 18 lbs boost untill second gear with my .70 a/r turbine housing, and this week when finish converting my turbo flange to fit the new .58 a/r housing, i should get alot sooner spool. im also going to wrap my uppipe to help with the spool time. I love the motor Ron made me, I honestly broke it in very roughly just how it should be. we did partial throttle .6 bar pulls from 4-6k rpms for the first 100 miles and were boosting more like .8 bar after around 200 miles. I guess its alittle buit of a debate on how to break in a motor, but it seemed to workk pretty welll. Now when i drive around, i dont have to worrie about downshifting and running the motor up to redline for pretty good periods of time. Without getting my self in trouble, i took a 400 mile road trip with a friend, and we averaged 120 the whole way, and i never experienced any issues with engine heat, oil temp or anything else. We didnt burn any oil off ar anything either so Im very pleased.
jared nelson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.