Welcome to the North American Subaru Impreza Owners Club Saturday November 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 02-16-2004, 01:09 PM   #1
Scooby Guru
Member#: 25243
Join Date: Sep 2002
Chapter/Region: SCIC
Location: South Pasadena, CA
2006 Legacy Outback

Default "Check Engine" warning light question ...

On the way home from the San Diego Solo II ... my Check Engine light came on ... we did the obvious, checked water, oil, fuses ... made sure the gas cap was on three clicks ... light is still on ... although the manual says it might take a few trips for it to reset itself ... what should I do if it doesn't go out ... dealer (w/ my mods) or a private garage like Scooby Specialties?

I have a '03 WRX Wgn with EcuTek dual maps, Stromung downpipe back exhaust system ending with a Prodrive muffler, APS up pipe, APS aluminum IC intake, STI IC.
20K on the car ...
* Registered users of the site do not see these ads.
makofoto is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-16-2004, 01:42 PM   #2
Scooby Specialist
Member#: 16876
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: St Paul, MN
2002 Impreza WRX
WR Blue


Well, since you live in California, you're out of luck when it comes to the free Autozone method. Might try posting in your regional forum to see if anyone near you has an OBDII scanner that you could borrow briefly.

I assume you have some sort of fix (e.g., PonyExpress MIL eliminator) for the P0420?

Zola is offline   Reply With Quote
Old 02-16-2004, 01:43 PM   #3
Jon [in CT]
*** Banned ***
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
02 WRX Sedan


Originally posted by makofoto
... my Check Engine light came on ... we did the obvious, checked water, oil, fuses ...
Actually, the only obvious thing to check when the CEL comes on is the trouble code stored in the OBD computer. Find someone with an OBD scan tool.
Jon [in CT] is offline   Reply With Quote
Old 02-16-2004, 09:08 PM   #4
Scooby Specialist
Member#: 11218
Join Date: Oct 2001
Chapter/Region: SCIC
Location: Orange, CA
2005 Legacy GT Wagon
99 Miata, 91 Miata turbo


I've got a scan tool in Irvine, you're welcome to come down and use it.

But you can probably find someone closer by posting in SCIC.
Evan is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Defi Warning light question? SCOOBY2.5RS Electrical & Lighting 2 03-30-2007 10:12 PM
Air Intakes and that orange "Check Engine" light Norris Normally Aspirated Powertrain 5 06-02-2003 03:52 PM
Day 1, "Check Engine" Light also?! Stickaru STi Forum Archive 0 06-01-2003 12:53 AM
"Check engine" light on wi/ cold air intake Subbieddie Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 11-14-2002 01:36 PM
Anyones "check engine" light came on after K& N air filter was installed? Rozos Newbies & FAQs 11 11-05-2001 02:44 PM

All times are GMT -4. The time now is 12:38 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.