Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-16-2004, 10:03 PM   #1
Mr. Mercado
Scooby Newbie
 
Member#: 36559
Join Date: May 2003
Location: Toronto, Ontario (T.O.)
Vehicle:
2003 Impreza WRX
WRB

Default HELP! Both Low Beams out!

Hey guys,

BOTH low beams are out on my WRX, but my high beams work just fine.

Anybody have any idea what the problem is? My parking brake is fully down, and the switch is positioned on. What are the odds that BOTH bulbs are blown?

PLEASE HELP!

Thanks,

Ryan
* Registered users of the site do not see these ads.
Mr. Mercado is offline   Reply With Quote
Old 02-16-2004, 11:00 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

It's very possible that both low beams are blown. If you haven't disabled your DRLs the low beams are on all the time and will burn out sooner than they would normally. Also if you happen to have aftermarket bulbs they tend to not last as long as OEM type ones.
Mulder is offline   Reply With Quote
Old 02-17-2004, 05:17 AM   #3
nhluhr
John Wayne Toilet Paper
Moderator
 
Member#: 7327
Join Date: Jun 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2008 Mazdaspeed3
2006 Wrangler Sport

Default

it's easy enough to remove the driver side bulb to take a look at it... check if either of the filaments is burned and just dangling there. The "lowbeam" filament is the one right in the center of the glass whereas the highbeam filament is the one that's off-center inside the glass...

(this is for a 9007 bulb which is what comes in the '02/'03 wrx)
nhluhr is offline   Reply With Quote
Old 02-17-2004, 03:10 PM   #4
BLOW
Scooby Newbie
 
Member#: 33477
Join Date: Feb 2003
Location: Central East Coast
Default

I had that happen once, the dealer replaced a fuse in the engine bay fuse box I think. But it was a fuse problem
BLOW is offline   Reply With Quote
Old 02-17-2004, 07:55 PM   #5
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

A blown fuse will take out both high and low beams as the headlights have common power. Also there are separate fuses for the left and right sides.
Mulder is offline   Reply With Quote
Old 02-17-2004, 11:34 PM   #6
Mr. Mercado
Scooby Newbie
 
Member#: 36559
Join Date: May 2003
Location: Toronto, Ontario (T.O.)
Vehicle:
2003 Impreza WRX
WRB

Default

hey guys,

took a peek at the bulbs, and yes they were blown. What are the odds that both went.

The sad thing was is that they were PIAA!

Thanks for your help!
Mr. Mercado is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Both low-beams went out at the same time..help! andron Electrical & Lighting 14 03-03-2011 11:10 PM
both low beams went out at the same time, huh? pumpkyn Electrical & Lighting 5 08-28-2007 09:12 PM
low beam out, but high beam still works? pogomonkey Electrical & Lighting 2 12-08-2004 03:13 AM
Both low beams are gone! OBSS General Forum Archive 7 02-01-2001 07:45 AM


All times are GMT -4. The time now is 10:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.