Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-17-2004, 12:11 AM   #1
blown327hk
Scooby Newbie
 
Member#: 46163
Join Date: Oct 2003
Vehicle:
89 rs legacy
grey

Default scooby noobie

i have a new zealand spec rs legacy with the standart ej20t but a td05 turbo off a '95 wrx, exhaust etc, and the std top mount intercooler.

problem is it's only running 4psi... does asny one know why? is there a leak anywhereetc...

please help
* Registered users of the site do not see these ads.
blown327hk is offline   Reply With Quote
Old 02-17-2004, 12:23 PM   #2
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

That very much sounds like a leak, either in your intake piping or in your vaccum lines...
Matt Monson is offline   Reply With Quote
Old 02-28-2004, 05:37 PM   #3
legacy92ej22t
Scooby Specialist
 
Member#: 42659
Join Date: Sep 2003
Chapter/Region: MAIC
Location: Williamsport PA/SilvrSprngs MD
Vehicle:
92 Legacy turbo5mt
All go and no show...

Default

The wastegate actuater on a TD05 is 9 psi right? So it probably isn't a bad boost control solenoid.
legacy92ej22t is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Scooby noobie needs help GDub Off-Topic 19 11-13-2002 11:31 PM
New England Scooby Nooby Introduction joeyproulx New England Impreza Club Forum -- NESIC 16 08-22-2002 11:52 AM
Scoobie Noobie! ezekiel044 Newbies & FAQs 7 10-04-2001 10:19 PM
Scoobie Noobie ezekiel044 Newbies & FAQs 2 09-26-2001 08:03 AM


All times are GMT -4. The time now is 06:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.