Welcome to the North American Subaru Impreza Owners Club Thursday January 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-17-2004, 09:37 AM   #1
BrianH
Bing user
Moderator
 
Member#: 44383
Join Date: Sep 2003
Chapter/Region: MWSOC
Default Greddy 60MM Electronic EGT Gauge

I've got the 60mm electronic greddy EGT gauge , and it works fine the only problem is that it doesn't light up when I turn my lights on. I know that the wiring in it works as I can plug it into either my boost or my oil pressure gauge and it works fine. Has anyone ever torn into one of these and dissasembled it? Is there any chance of it just being something burned out? The gauge itself does its job just fine, illumination is the problem.

Thanks
* Registered users of the site do not see these ads.
BrianH is offline   Reply With Quote
Old 02-17-2004, 12:15 PM   #2
tdxflex
Scooby Specialist
 
Member#: 13634
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Boston
Vehicle:
2002 WRX
WRB

Default

Get a multimeter or test light and check the illumination wire from the gauge. If the bulb is burnt, it should just be an open circuit and the illum wire should still read 12v. If it doesn't read 12v, I would guess either the connection or the wrong wire was used, but probably not the wrong wire since you said it's the same one for your other gauges. Are you use crimp, solder, or vampire clips?
tdxflex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Greddy 60mm electrical EGT gauge gomikeyp Electrical & Lighting 3 06-19-2006 09:49 AM
FS: GReddy 60mm electronic temp gauge Peak/warning Twerthi Private 'For Sale' Classifieds 6 08-28-2005 12:34 AM
FS : NJ / Greddy 60mm Electronic Boost Gauge TRICMAN2004 Private 'For Sale' Classifieds 6 04-30-2005 07:43 PM
FS: Greddy 60mm Electronic Boost Gauge Tb311 Private 'For Sale' Classifieds 6 09-21-2004 06:17 PM
Ca: Greddy 60mm electronic boost gauge, kartboy shifter bushings, pictures inside STEALTH-WRX Private 'For Sale' Classifieds 4 02-13-2004 01:08 PM


All times are GMT -4. The time now is 08:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.