Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-22-2004, 05:41 AM   #1
SubyWRXer
Scooby Newbie
 
Member#: 43137
Join Date: Sep 2003
Chapter/Region: SCIC
Location: Los Angeles, CA
Vehicle:
2005 Legacy GT LTD
Black

Default need help

when i step on the gas, the rpm goes up fast to about 4500 then drops back to about 2500 then climbs back up slowly... it happens in all gear except 1st gear.. any ideas? will utec cause this?
* Registered users of the site do not see these ads.
SubyWRXer is offline   Reply With Quote
Old 02-22-2004, 06:40 AM   #2
Psydotek
Scooby Guru
 
Member#: 44168
Join Date: Sep 2003
Chapter/Region: SCIC
Location: In your pant[ie]s.
Vehicle:
2003 Yellow WRX
with too many lights...

Default

Worn out clutch perhaps? Or you're slipping the clutch way too much when up-shifting...
Psydotek is offline   Reply With Quote
Old 02-22-2004, 02:20 PM   #3
Mike Wevrick
RIP 1/19/64 - 7/23/11
Scooby Guru
 
Member#: 24654
Join Date: Sep 2002
Chapter/Region: NESIC
Location: saraseager.com
Vehicle:
1957 Taggart Comet
atlasshruggedpart1.com

Default

If you have the clutch all the way out and your engine revs up without the car accelerating, than almost certainly your clutch is worn out.
Mike Wevrick is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Pressure switch 94 Leggy? Need Help DjKlown Legacy Forum 2 06-02-2010 06:42 PM
EJ25 build, need help! rcarlson87 Built Motor Discussion 0 06-02-2010 11:36 AM
Hard Drive Recover Help much needed... ATA RAID 0 knowledge needed HELP PLEASE!!! 2k2 Off-Topic 63 12-24-2003 11:35 PM
Need help! Perrin Fuel rails installed but I need help with Fuel Evap Line STR8OUT Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-18-2003 01:11 PM
Need help!Need flywheel bulletin from SOA.Please help. RallyeX General Forum Archive 3 06-01-2000 08:57 AM


All times are GMT -4. The time now is 07:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.