Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > 'Old School' Subaru Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-22-2004, 08:38 PM   #1
jjtdiceman
Scooby Newbie
 
Member#: 54926
Join Date: Feb 2004
Default new problem with 88 gl 10

I've got a 88 subaru gl 10 4wd 4cyl turbo. I had a problem with it not wanting to go over 56mph. I drove it the other day and turned it off for about 10 minutes. I tried to start it and it will barely idle now. It floods itself out. Gas will pour out the of the catalytic converter. It has a new fuel pump, filter, plugs, wires, cap, rotor, and everything is hooked up right. When i start it, gas comes out from between the turbo and the exhaust. If that gasket is bad, will it cause it to flood out? I tried removing the air filter to allow more fuel and it still flooded out. It's getting plenty of spark. I looked inside the turbo and the turbine turns fine, but there is a small amount of oil in there. Is the turbo bad? If so, can i just disconnect the turbo and run a pipe in place of it? I really need to get this car fixed.
* Registered users of the site do not see these ads.
jjtdiceman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with my GL 10 Tranny woes! Jeramiah 'Old School' Subaru Forum 2 02-17-2007 12:27 AM
88 gl-10 engine swap chevelle8389 'Old School' Subaru Forum 5 11-23-2006 11:37 PM
problems with 88 legacy jjtdiceman Legacy Forum 3 02-12-2004 06:20 PM
22B vents on 88 GL-10 XT6Wagon Interior & Exterior Modification 6 11-06-2000 05:56 PM


All times are GMT -4. The time now is 05:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.