Welcome to the North American Subaru Impreza Owners Club Saturday May 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-24-2004, 03:06 AM   #1
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default P0016, why do you haunt me so?

Man, it's every other month with this damn code. We've done a MAP sensor, Air Injector, reflashed the ECU, and still that sob comes on. Anyone? Bueller, Bueller?

-RYan
* Registered users of the site do not see these ads.
RK Performance is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-24-2004, 11:18 AM   #2
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

what's the code mean??
HndaTch627 is offline   Reply With Quote
Old 02-24-2004, 06:05 PM   #3
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Quote:
Originally posted by HndaTch627
what's the code mean??
cant find that in any subaru listing I have access to, so yea same question?

Jay
munkis is offline   Reply With Quote
Old 02-24-2004, 11:42 PM   #4
Patrick L
Scooby Specialist
 
Member#: 634
Join Date: Dec 1999
Chapter/Region: TXIC
Location: Tulsa, OK
Vehicle:
2000 Impreza 2.5RS
Becasue ITS racecar

Default

P0016 - Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor A
Patrick L is offline   Reply With Quote
Old 02-25-2004, 02:43 AM   #5
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default

Quote:
Originally posted by Top_Dog
P0016 - Crankshaft Position - Camshaft Position Correlation Bank 1 Sensor A
Nope, I'm a complete dumbass... I am currently kicking myself for typing the wrong number.

Okay, let's try this one more time...

P0065, why do you haunt me so?

P0065 Air assist injector solenoid valve malfunction
Select Monitor says something more like "Air assist injector solenoid malfunction Range/Performance"

-RYan

Should I just delete this thread and start a new one? Mod can you fix the title?
RK Performance is offline   Reply With Quote
Old 02-25-2004, 02:52 AM   #6
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default

Quote:
Originally posted by HndaTch627
what's the code mean??
How's the Link coming... if I get that installed I don't have to worry about this crap anymore!?

-RYan
RK Performance is offline   Reply With Quote
Old 02-25-2004, 04:09 AM   #7
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by RK Performance
How's the Link coming... if I get that installed I don't have to worry about this crap anymore!?

-RYan
sending you pictures tommorrow so you know it exists and also burning the 2 manuals(link plus manual) and RS ECU manual to a CD for ya. I gotta try to find the maps for ya.

AS for the code, have you made sure all the injector tips are clear and not clogged by any kind of debris??

Jeremy
HndaTch627 is offline   Reply With Quote
Old 02-25-2004, 04:12 AM   #8
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default

Quote:
Originally posted by HndaTch627
sending you pictures tommorrow so you know it exists and also burning the 2 manuals(link plus manual) and RS ECU manual to a CD for ya. I gotta try to find the maps for ya.

AS for the code, have you made sure all the injector tips are clear and not clogged by any kind of debris??

Jeremy
Yup, replaced them also just to be sure. Along with the MAP sensor for whatever reason the Subaru Tech wanted to foot the bill, and reflash. I am convinced my car is haunted. Eh, it will all be over soon, I was just curious if anyone else has experienced this little gem of a CEL.

-RYan
RK Performance is offline   Reply With Quote
Old 02-25-2004, 11:41 AM   #9
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

have you replace the Air Injection Solenoid and or made sure it's plugged in?

why did they replace the MAP before that??

Jeremy
HndaTch627 is offline   Reply With Quote
Old 02-25-2004, 11:47 AM   #10
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default

Solenoid was replaced. As for the MAP, I have no idea. That was the Subaru Tech line's call. I think the car may just hickup. The CEL usually pops after I've been cruising and lift the throttle to slow down. Car runs fine so who knows.

-Ryan
RK Performance is offline   Reply With Quote
Old 02-25-2004, 03:57 PM   #11
Matt
Allergic to turbos
Moderator
 
Member#: 181
Join Date: Aug 1999
Chapter/Region: MAIC
Location: MAIC & Southeast
Vehicle:
2009 Forester

Default

I had that exact code about 10 times on my '01 Rs. Had the solenoid replaced and kept getting the code at completely random intervals....or so I thought.

Turns out that when I got gas at one of three gas stations, Citgo, Chevron, and Hess, (all in the same geographic area) the light would come on after a day or two of driving. I stopped getting gas at these places and never saw it again...20k miles after that I traded the car in and didn't see the light at all.

Try getting a different brand/octane and see what happens.
Matt is offline   Reply With Quote
Old 02-26-2004, 03:07 PM   #12
RK Performance
Scooby Specialist
 
Member#: 19069
Join Date: May 2002
Chapter/Region: RMIC
Location: Thornton CO
Vehicle:
2005 Impreza WRX
2002 RS, RIP

Default

Quote:
Originally posted by matt in fl
I had that exact code about 10 times on my '01 Rs. Had the solenoid replaced and kept getting the code at completely random intervals....or so I thought.

Turns out that when I got gas at one of three gas stations, Citgo, Chevron, and Hess, (all in the same geographic area) the light would come on after a day or two of driving. I stopped getting gas at these places and never saw it again...20k miles after that I traded the car in and didn't see the light at all.

Try getting a different brand/octane and see what happens.

This is interesting, I pretty much always get the same gas from the same place. Sometimes I don't. I get the code it seems every 4000-5000 miles. So why just evey once in a while?

-Ryan
RK Performance is offline   Reply With Quote
Old 05-08-2014, 12:32 PM   #13
subiedude13
Scooby Newbie
 
Member#: 390256
Join Date: May 2014
Location: LV, PA
Vehicle:
2002 Impreza 2.5RS

Default

Hi, new to the forums for posting and giving feedback. I normally just used to browse. I also am experiencing the P0065 code for air assist injector control range/performance. I'm going to try and inspect the solenoid itself today and maybe pull out the injectors to inspect them also. Just trying to figure out what most people did to fix this code because I cleared it two times and it has came back on both times. The second time it took a little for it to come back. First time came back maybe 100 miles, second time was like 200. I have already used fuel injector cleaner in this car and I did notice a gain in engine performance but I am still running into this code. Any help?
subiedude13 is offline   Reply With Quote
Old 05-08-2014, 07:10 PM   #14
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

I'd yell at you for bumping a 10 year old thread, but at least it's on-topic. I haven't had this code, but have you checked the rubber lines?
yarrgh is online now   Reply With Quote
Old 05-09-2014, 08:44 AM   #15
subiedude13
Scooby Newbie
 
Member#: 390256
Join Date: May 2014
Location: LV, PA
Vehicle:
2002 Impreza 2.5RS

Default

I couldn't make my own thread due to just making my account. But yes I checked everything last nite. Turns out I think it was just the connector that goes to the valve was just loose. I wiggled it around, pushed it in and started it up this morning and the cel isn't on anymore.
subiedude13 is offline   Reply With Quote
Old 05-09-2014, 01:58 PM   #16
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

Good to hear it was an easy fix.
yarrgh is online now   Reply With Quote
Old 05-11-2014, 02:05 PM   #17
subiedude13
Scooby Newbie
 
Member#: 390256
Join Date: May 2014
Location: LV, PA
Vehicle:
2002 Impreza 2.5RS

Default

It came back. Does the valve go bad sometimes? Car is at 163k
subiedude13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oh hydrocodone, why do you love me so sweet? -=C=- Off-Topic 89 09-02-2014 02:01 PM
Big Mac, why do you torment me so? MUGWUMP Off-Topic 33 12-03-2008 11:15 PM
Insomnia, why do you torment me so? merilee Off-Topic 33 11-13-2006 02:18 PM
why do you call me to tell me that.. alacrity024 Off-Topic 7 03-06-2006 12:23 PM
Dear God, Why do you hate me so? obyone Mid West Subaru Owners Club Forum -- MWSOC 5 08-20-2003 04:50 PM


All times are GMT -4. The time now is 10:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.