Welcome to the North American Subaru Impreza Owners Club Friday July 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Car Part Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-19-2009, 07:38 PM   #1
juanmedina
Scooby Guru
Member Sales Rating: (31)
 
Member#: 133146
Join Date: Nov 2006
Location: SC
Vehicle:
07 FPgreen 7.37@95
WRX VF39+E85 12.0, 121mph

Thumbs down Innovative LC-1 sucks

I got a LC-1 like 5 months ago it work for about 2 months and than it crap on me, it was stock on 7.4 AFR and flashing. I fill out a RMA and they send me a new controller.

I installed the new controller it worked fine for about 3 weeks than it started to count up and then hit 22.4, and from there bounce between 22.4 and 7.4. flashing at 7.4. This time I though I needed a new sensor, so I got a new bosch sensor, try the recalibration and it did the same thing.

I know the sequence by memory, unplug the sensor for 10 sec, then plug the sensor for 2 minutes, then press the led for 3 sec, and let it recalibrate at air, and finally install the sensor on the exhaust.

The led is flashing 2 time/sec, than 4 times/sec, but than it just turns on and stays on at 22.4 AFR, when I tap the gas it goes to 7.4 AFR and flashes. I have spend money on shipping, on a new sensor, time etc. I am piss , this wideband is a piece of crap. I am going to fill out a RMA again, I hope they send me a new one, but prefer if they return my money .

Recommend me another wide band, does the AEM wideband uses the same type of sensor?

Thanks
* Registered users of the site do not see these ads.
juanmedina is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-19-2009, 08:22 PM   #2
tom@kartboy
NASIOC Vendor
Vendor Sales Rating: (60)
 
Member#: 67
Join Date: Jul 1999
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
1999 Outlasting
the competition.

Default

zetronics FTMFW. i went through at least 4-5 LC-1's till i found the ZT2 setup. best of all you dont have to do that stupid air calibration.
__________________
Tom Deadrick

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
American Made Shift!
tom@kartboy is offline   Reply With Quote
Old 02-19-2009, 11:16 PM   #3
Baay
Scooby Newbie
Member Sales Rating: (2)
 
Member#: 139645
Join Date: Feb 2007
Vehicle:
07 WRX
UGM

Default

Hmm ive been looking for a new AFR too, ill give the ZT2 with their new LCD screed a shot, i like that its can read the OBD codes too.
Baay is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Innovate LC-1 wideband, Innovate XD-16 gauge (w/pod) EdsWRX MAIC Private Classifieds 12 03-08-2010 10:42 PM
FS: Innovate LC-1 wideband, Innovate XD-16 gauge (w/pod) EdsWRX Engine/Power/Exhaust 23 11-19-2009 09:38 PM
FS: Innovate LC-1 wideband, Innovate XD-16 gauge (w/pod), Defi gauge setup (w/ pod) phlegmon MAIC Private Classifieds 4 09-10-2009 11:39 PM
FS: Innovate LC-1 wideband, Innovate XD-16 gauge (w/pod), Defi gauge setup (w/ pod) phlegmon Engine/Power/Exhaust 8 09-09-2009 10:28 PM
WTT: Innovate LM-1 for Innovate LC-1 w/ XD-16 Gauge Subarutex NWIC Private Classifieds 0 09-13-2006 01:24 AM


All times are GMT -4. The time now is 01:40 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.