Welcome to the North American Subaru Impreza Owners Club Monday November 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-27-2004, 05:26 PM   #1
leecea
Scooby Guru
 
Member#: 37359
Join Date: May 2003
Vehicle:
2003 WRX

Default Antifreeze smell in cabin occasionally

I thought I'd seen a thread about this a while ago but now I can't find it with Search. I recently started getting a faint smell of antifreeze occasionally when I'm driving. Is this something others have experienced? What's the cause?
* Registered users of the site do not see these ads.
leecea is offline   Reply With Quote
Old 02-29-2004, 10:08 PM   #2
ImprezaVA
Scooby Specialist
 
Member#: 32846
Join Date: Feb 2003
Chapter/Region: MAIC
Location: Elkton, VA
Vehicle:
1998 Impreza L-SOLD
Arcadia Green

Default

I was going to say heater core, but your car is an '03. Do you see any coolant leaking anywhere in the engine bay? I haven't had any trouble with my subaru but I had a turbo probe that kept blowing the coolant supply to the turbo. Finally found that the exhaust manifold cover was cutting the hose, nontheless, I had that sweet antifreeze smell.

-Charles-
ImprezaVA is offline   Reply With Quote
Old 03-01-2004, 10:06 AM   #3
leecea
Scooby Guru
 
Member#: 37359
Join Date: May 2003
Vehicle:
2003 WRX

Default

I haven't seen anything obvious, but I'll try and do a more thorough inspection soon. I'm also going to try and monitor the coolant level to see if it is actually being depleted.

Funny thing is that yesterday I did a one hour 80 mph trip to an autox and back, with a bunch of autox runs in between, and got no smell. Then on my gentle commute this morning, I got a slight of coolant smell at one point.
leecea is offline   Reply With Quote
Old 03-02-2004, 12:25 PM   #4
BryanH
Scooby Guru
 
Member#: 993
Join Date: Feb 2000
Chapter/Region: MAIC
Location: nova
Default

i have the exact same thing. 03 wrx and all. Its really annoying. I was trying to figure out a pattern to it but I am stumped.

I have checked all the hose clamps and they all seem to be tight. The antifreeze level seems to be staying constant.
BryanH is offline   Reply With Quote
Old 03-02-2004, 06:52 PM   #5
leecea
Scooby Guru
 
Member#: 37359
Join Date: May 2003
Vehicle:
2003 WRX

Default

I guess my search hand't been wide enough before. If you search on "antifreeze smell" across all forums and for the last 6 months it turns up a whole slew of threads. Tons of people with everything from leaking radiators, to hoses, to unresolved problems. Almost too much info to be helpful, but it gives me a few things to look for. I hate the thought of taking the car in to the dealer, but it may come to that.
leecea is offline   Reply With Quote
Old 03-03-2004, 04:59 AM   #6
macroman
Scooby Newbie
 
Member#: 40056
Join Date: Jul 2003
Vehicle:
2000 legacy L wagon
wintergreen

Default

could be a leaking head gasket....
macroman is offline   Reply With Quote
Old 03-09-2004, 04:21 AM   #7
valleywrx
NASIOC Supporter
 
Member#: 53257
Join Date: Jan 2004
Chapter/Region: SCIC
Location: LA, CA / JP
Default same problem

I have the same problem from upgrading my radiator pressure cap to the STi one. Within a week the anitfreeze smell was coming in but more like a burning one. Then took it to the dealer and said that the problem was a leaking hose. They fixed it only to my disappointment . I have now white smoke and it smells like anitfrezze being burned coming out of the hood scoop when Im idling at the stop light.

but funny thing is there is no pattern to it. it comes and goes. Im taking it back tot he dealer to get it fixed properly. I also did not have any change in coolant levels. It wasnt eating the stuff up faster.It just leaks somehow and makes that smell. Cant figure it out and its annoying.
valleywrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas smell in cabin...not so much in engine bay? Jard Mid Atlantic Impreza Club -- MAIC 39 03-24-2006 12:51 PM
Turbo back and exhaust smell in cabin? ChrisF Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 11-08-2002 11:34 PM
Oil smell in cabin? PunksWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 05-03-2002 11:39 PM
Exhaust smell in cabin gavin Legacy Forum 4 04-24-2002 12:25 AM


All times are GMT -4. The time now is 08:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.