Welcome to the North American Subaru Impreza Owners Club Friday October 9, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 03-10-2004, 05:32 PM   #1
Scooby Newbie
Member#: 45737
Join Date: Oct 2003
2004 WRX STi

Default my air conditioner isnt working

hey i have a 2004 wrx sti. i installed my turbo timer, and my air conditioner isnt working. it doesnt blow air in the car. i checked the fuses, and it they are fine. i plugged the wire4s back together back to normal(the harness wires) and its still not blowing air. its like 85 out today and it sucks without air. can someone please help me? thanks!

* Registered users of the site do not see these ads.
dashiet is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-10-2004, 11:53 PM   #2
Scooby Guru
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Team Broken: V6 GF


You mean the blower motor is not turning on at all in any position?

munkis is offline   Reply With Quote
Old 03-13-2004, 11:13 AM   #3
Mike Wevrick
RIP 1/19/64 - 7/23/11
Scooby Guru
Member#: 24654
Join Date: Sep 2002
Chapter/Region: NESIC
Location: saraseager.com
1957 Taggart Comet


Try taking out the turbo timer (which you don't need anyway) and restoring everything to the way it was originally.
Mike Wevrick is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Conditioner Not Working seanr2 Baja Forum 8 05-15-2009 03:09 PM
Can anyone recommend a good place to service my air conditioner? Yossarian Bay Area Impreza Club Forum -- BAIC 0 08-04-2008 06:52 PM
Air conditioner not working - AT ALL. RallyFord Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 09-01-2004 10:28 AM
air conditioner not working FinalBean Service & Maintenance 5 04-27-2004 07:53 PM
help! my air conditioner isnt working dashiet Service & Maintenance 3 01-10-2004 06:24 PM

All times are GMT -4. The time now is 06:33 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.