Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Outback Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2004, 01:31 PM   #1
Bricoleur
Scooby Newbie
 
Member#: 57157
Join Date: Mar 2004
Default Engine Hesitation and Check Engine Light

My 1999 Outback has had an intermittent problem for a while now, where the engine hesitates during acceleration/braking. Coming off the highway onto a ramp for example, or when a burst of power is needed going from level road to climbing a hill. Lately, it started displaying this behavior when coming off from a standing start, so I took it in to the dealer today.

According the mechanic, the coil is corroded and valve covers are leaking. He thinks the coil is the main culprit, with the valve covers something that should be done in the near future. He estimates $425 or so for the coil, $550 or so for the valves.

Does this sound unreasonable to folks? Searching around for the parts, the prices seem about in line, and I knew the valves were going to need some work in the near future. A new car isn't in the cards this year, so getting this one fixed up is the best option; I just don't want to get scalped on the repairs.

Any advice appreciated,
=John
* Registered users of the site do not see these ads.
Bricoleur is offline   Reply With Quote
Old 03-21-2004, 09:46 PM   #2
Vicville
Scooby Newbie
 
Member#: 50874
Join Date: Dec 2003
Location: BC Canada
Vehicle:
98 Outback Ltd
Black

Default

You put the words "and Check Engine Light" in your subject line, then didn't refer to it. I think if your light is coming on, you should be able to get a good diagnosis of the problem via an onboard systems diagnostics tool. (I go to an independent mechanic, not Subaru for this. It's cheaper and has been way more accurate.) Auto Zone shops will usually do it for free, too, and help you figure out what the codes mean.
My '98 OB has always had a bit of hesitation, and it's worse at cold start in winter. (A K&N air filter has helped some, but slight hesitation is still there)... At the least, I'd get a second opinion about the coil/valves.
Vicville is offline   Reply With Quote
Old 03-22-2004, 08:09 AM   #3
RidinLow
Scooby Guru
 
Member#: 329
Join Date: Sep 1999
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1995 325i
Arctic Gray

Default

He's not gonna touch the valves at all, just the covers. All the EJ25 valve covers seem to end up leaking... I know my '97 drips oil all over the place.

$550 for the valve covers is a great price... for the mechanic! All you need are a few gaskets per side, unbolt the valve cover on each side, then replace gaskets and put it back together!
RidinLow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
injector connectors and check engine light Barticus Electrical & Lighting 1 08-19-2004 12:18 PM
Cruise Control and Check Engine Light.. i need help!! PhatAsiankid03 Electrical & Lighting 9 04-02-2004 03:07 PM
Need help turbo now sputers and check engine light is on! AWJunkies Normally Aspirated with bolt-on Forced Induction Powertrain 2 07-18-2003 01:21 AM
Air Filter and Check Engine Light pro2cer604 Vancouver Impreza Club Forum -- VIC 6 03-17-2002 06:00 PM


All times are GMT -4. The time now is 03:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.