Welcome to the North American Subaru Impreza Owners Club Tuesday July 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Forester Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-30-2004, 05:32 PM   #1
BrysImpreza
Scooby Guru
 
Member#: 3102
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Northern, CT
Vehicle:
2012 Sport Limited
Ice Silver

Default Opinions on my Amp and Gauge Install

The first pic is of my amp installed in the spot where the jack was formally placed. As you can see it was a fairly easy place to locate a smaller amp. The jack was relocated next to the spare tire.



Next is the Gauge pod install, it was a near direct fit with my faux carbon fiber pod. The electrical was tapped off the harness from the factory sunroof (I have an aftermarket with a separate electrical feed). The EGT feed was run up the passenger side A pillar, through the firewall and into the exhaust manifold.
The A/F gauge is the one on the left.
Maplights still work fine, front sunglass holder intact.

no cutting, very little drilling and no wires to be seen!

* Registered users of the site do not see these ads.
BrysImpreza is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-30-2004, 05:52 PM   #2
SASniper
Scooby Newbie
 
Member#: 57913
Join Date: Mar 2004
Default

Eeeek! Watch that Chev behind you ... I wouldn't break hard

Nice install ... not my cup of tea ... but very clean

How did you wire up your amp? Are you using stock head unit and speakers?
SASniper is offline   Reply With Quote
Old 03-30-2004, 05:56 PM   #3
BrysImpreza
Scooby Guru
 
Member#: 3102
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Northern, CT
Vehicle:
2012 Sport Limited
Ice Silver

Default

I tapped an RCA convertor off the stock amp send for the sound input, the remote is on the cigarette lighter, power to the battery and ground... obvious

I see you like my truck too
BrysImpreza is offline   Reply With Quote
Old 03-30-2004, 07:00 PM   #4
enewtabie
Scooby Guru
 
Member#: 18928
Join Date: May 2002
Chapter/Region: South East
Location: Butner,Stem NC
Vehicle:
2002 jdm wrx v7/v8
inter/w Spec C roof vent

Default

Can you take a further back photo and maybe one at night..
I would be interested in how it looks.
enewtabie is offline   Reply With Quote
Old 03-31-2004, 02:57 PM   #5
mgenti
Scooby Newbie
 
Member#: 41552
Join Date: Aug 2003
Location: Huntsville, AL USA
Vehicle:
2004 Forester XT
Plantinum Silver Metallic

Default

I guess I would just be worried the amp might get to hot. What about doing plexi glass with some vent holes?
--Mark
mgenti is offline   Reply With Quote
Old 03-31-2004, 03:24 PM   #6
BrysImpreza
Scooby Guru
 
Member#: 3102
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Northern, CT
Vehicle:
2012 Sport Limited
Ice Silver

Default

I actually have a fan and venting combo I'm going to install soon, it was just getting dark and cold when I did this install
BrysImpreza is offline   Reply With Quote
Old 03-31-2004, 04:07 PM   #7
Caddy Daddy
Scooby Specialist
 
Member#: 11070
Join Date: Oct 2001
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
2004 SG9, Audi S8
Ducati ST2, BMW R100/7

Default

nice chevy. you got a picture from the backseat of the gauges? looks like a clean install good job
Caddy Daddy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opinion on Sub/Amp combo WrexT Car Audio, Video & Security 13 05-24-2006 07:33 PM
Opinions please on my charts after 20g install mycotopian Engine Management & Tuning 6 09-22-2005 01:03 AM
ebay top-mount i found, what do you guys think? And want opinion on my setup too. deuce189 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 03-22-2005 06:09 PM
A need you opinions on whether I should install a wing on my WRX and some other... faceplate Interior & Exterior Modification 3 07-15-2002 10:37 PM
Opinions on Crunch Amps? rossman Car Audio, Video & Security 3 04-02-2002 09:13 PM


All times are GMT -4. The time now is 09:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.