Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
New England Subaru Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > New England Impreza Club Forum -- NESIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-01-2004, 09:27 AM   #1
sen
Scooby Newbie
 
Member#: 1216
Join Date: Apr 2000
Chapter/Region: NESIC
Location: Haverhill MA
Vehicle:
2007 WRX
WR Blue

Unhappy Flashing Oil Light?

I have a 2003 Forester that had a flashing yellow at oil temp light, which the owners manual says it is a Trans problem. Any one else have this problem? HELP
* Registered users of the site do not see these ads.

Last edited by sen; 04-01-2004 at 09:57 AM.
sen is offline   Reply With Quote
Old 04-01-2004, 09:31 AM   #2
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

have you checked your oil?
Davenow is offline   Reply With Quote
Old 04-01-2004, 09:38 AM   #3
kevinsUBARU
Scooby Specialist
 
Member#: 2263
Join Date: Sep 2000
Chapter/Region: Tri-State
Location: Funky Kingston, NY
Vehicle:
2012 Impreza Sport

Default

dipstick
kevinsUBARU is offline   Reply With Quote
Old 04-01-2004, 09:54 AM   #4
Those Meddling Kids
Scooby Specialist
 
Member#: 4140
Join Date: Feb 2001
Chapter/Region: NESIC
Location: Hingham, MA
Vehicle:
02 WRX
00 MR-S

Default

tranny overheating?

were you driving up hill all day? I had heard somewhere slipage in the tranny could cause it to overheat.

hopefully it is a bad sensor (ie false error).

TMK
Those Meddling Kids is offline   Reply With Quote
Old 04-01-2004, 09:59 AM   #5
sen
Scooby Newbie
 
Member#: 1216
Join Date: Apr 2000
Chapter/Region: NESIC
Location: Haverhill MA
Vehicle:
2007 WRX
WR Blue

Unhappy update

It is my Wifes car, it was the yellow at oil temp light. I am going to check the fluid levels at lunch. I am just looking to see it their is a trany recall that this could be linked to.
sen is offline   Reply With Quote
Old 04-01-2004, 10:02 AM   #6
marcus12
Scooby Specialist
 
Member#: 45613
Join Date: Oct 2003
Chapter/Region: NESIC
Location: Columbia, CT
Vehicle:
2005 Legacy GT Ltd.
Satin White Pearl

Default

I have no clue about cars newer than, well, mine...but could it be a tranny fluid thing? Is your car standard 5-spd, or automatic transmission? If it's auto, you can check the fluid level right under the hood. If it's a 5-spd, there should be a yellow dipstick sticking out of the gearbox.

It also could just be low oil level - so check your oil while you're at it! Good luck!

//marcus
marcus12 is offline   Reply With Quote
Old 04-01-2004, 11:33 AM   #7
KD7000
Scooby Specialist
 
Member#: 16653
Join Date: Mar 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2012 Mazda 3
2004 Honda Pilot

Default

Quote:
Originally posted by marcus12
I have no clue... Is your car standard 5-spd, or automatic transmission?
Quote:
at oil temp light
KD7000 is offline   Reply With Quote
Old 04-01-2004, 11:40 AM   #8
sen
Scooby Newbie
 
Member#: 1216
Join Date: Apr 2000
Chapter/Region: NESIC
Location: Haverhill MA
Vehicle:
2007 WRX
WR Blue

Default Trany Type

It has a Auto Trany.
sen is offline   Reply With Quote
Old 04-01-2004, 11:47 AM   #9
Those Meddling Kids
Scooby Specialist
 
Member#: 4140
Join Date: Feb 2001
Chapter/Region: NESIC
Location: Hingham, MA
Vehicle:
02 WRX
00 MR-S

Default

any slippage? ie slow shift.

TMK
Those Meddling Kids is offline   Reply With Quote
Old 04-01-2004, 11:54 AM   #10
oric20
Scooby Specialist
 
Member#: 10235
Join Date: Sep 2001
Chapter/Region: NESIC
Location: Natick, MA
Default

Quote:
Originally posted by KD7000


Brian you are such a jerk! go easy on the dude!!
oric20 is offline   Reply With Quote
Old 04-01-2004, 12:07 PM   #11
KD7000
Scooby Specialist
 
Member#: 16653
Join Date: Mar 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2012 Mazda 3
2004 Honda Pilot

Default


I was going easy.

-Brian

Edit: to keep this on topic- Sen- if your tranny fluid level is ok, but the light still flashes, I'd call your dealer (presuming your car is still under warranty).
KD7000 is offline   Reply With Quote
Old 04-01-2004, 01:26 PM   #12
sen
Scooby Newbie
 
Member#: 1216
Join Date: Apr 2000
Chapter/Region: NESIC
Location: Haverhill MA
Vehicle:
2007 WRX
WR Blue

Thumbs up Looking better

Well the trany fluid level is OK and it does not smell burnt, looks nice and red. Hopefully just a fluke.
sen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
flashing oil temp indicator submariner416 North West Impreza Club Forum -- NWIC 5 04-23-2009 04:38 PM
AT Oil Light flashing.... metalsman Newbies & FAQs 7 03-26-2006 10:38 PM
Oil light occasionally flashes........why? riverarob Service & Maintenance 6 12-07-2005 04:15 AM
Check Engine light w/ flashing Cruise Light? SBasinger18 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 11 07-24-2004 12:55 AM
Flashing CE Light @6000 in 3rd? pleiades Normally Aspirated Powertrain 0 03-27-2001 08:25 PM


All times are GMT -4. The time now is 03:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.