Welcome to the North American Subaru Impreza Owners Club Saturday July 2, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Old 02-06-2001, 05:41 AM   #1
comcop
Scooby Newbie
 
Member#: 1378
Join Date: Apr 2000
Location: Indianapolis, IN, USA
Vehicle:
2005 Subaru WRX STi
Blue

Unhappy Check Engien light on?? After heave mods...

Hi, guys, my check engien light lighted up this morning while I was driving to school.

I had APEXi N1 Cat-Back Exhaust,APEXi Super AFC, and Weapon-R Air Intake installed. recently I have Unorthodox Racing Underdrive Pulley installed to my car. and 3 days ago I reset the ECU. and I'm pretty sure my S-AFC setting are all correct.

my car now is getting hiccups, and this morning the check engien light went on.

what could possibaly went wrong??

I do not have my S-AFC settings with me. but I will post it as soon as I get off work.

Comcop

[This message has been edited by comcop (edited February 06, 2001).]
* Registered users of the site do not see these ads.
comcop is offline  
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-06-2001, 06:32 AM   #2
tmat3
Scooby Specialist
 
Member#: 2817
Join Date: Nov 2000
Location: NYC and Troy, NY
Vehicle:
2001 Impreza 2.5RS
BRP

Post

I would take the S-AFC out, reset the ECU and see what happens. You can't bring the car to the dealer because S-AFC most likely kills the warranty.

What year is your car? If not MY00 or 01, maybe the intake killed your MAF sensor.
tmat3 is offline  
Old 02-06-2001, 06:34 AM   #3
MBX Motorsports
Scooby Newbie
 
Member#: 3726
Join Date: Jan 2001
Location: Newark, DE
Vehicle:
2001 2.5RS
Blue Ridge Pearl

Post

Best way to tune an AFC properly ... goto the dyno and do it. That'll guarantee you the best results.

If your check engine light is on ... it may be telling you that 1) You're running too lean or 2) You're running way too rich. Both of those cituations will trip the 02 sensor, thus tripping your engine light. Pull the engine codes from the car and see what you come up with. If you pull the 02 sensor, then your AFC is not setup correctly. If you don't know how to set it up, find someone around your area who does.

At least that's my .02 - or you can start putting back on your OEM parts and see which part turns the engine light back off again =)

Dave
2001 2.5RS
1977 Fiancee - Will trade.
MBX Motorsports is offline  
Old 02-06-2001, 06:57 AM   #4
comcop
Scooby Newbie
 
Member#: 1378
Join Date: Apr 2000
Location: Indianapolis, IN, USA
Vehicle:
2005 Subaru WRX STi
Blue

Post

My car is 99.

thanks for the help, guys!!
comcop is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS, Airbag, and Rear Diff light on after washing engine Acejam2k Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 06-02-2010 12:32 PM
HIGH+LOW on after Foglight mod, no fog lights (HELP?) segfau|t Electrical & Lighting 6 06-10-2008 11:03 AM
check engine light blinking after installins safcII for 99 2.5rs q0Y0p Electrical & Lighting 2 08-26-2003 08:59 PM
Check engine light on after intake install The1one4ever Normally Aspirated Powertrain 7 06-01-2002 02:25 AM
Tell me why my Check Engien light "ON"???? Help!!!!! comcop General Forum Archive 3 02-06-2001 06:58 AM

All times are GMT -4. The time now is 01:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.