Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 04-03-2004, 04:24 AM   #1
5spd Alcyone
Scooby Newbie
 
Member#: 34383
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Madison, WI
Vehicle:
1992 SVX-T3/T04E
Dark Teal Metallic

Angry battery got hooked up backwards, need help finding gremlins

Well to make a long story short, the battery got installed backwards in my SVX today. blew the fusable link. Fixed that and i have the following problemes:


1)radio works. The CD player dosnt work. But the lights on the cd player works and if i hit the eject button 2 times(yes only if twice) then the dash lights blink off for a second and then back on.

2)The clock is half lit. is keeping time perfectly.

3)Memory of stations resets everytime the car is started(radio is off when i turn it back on

4)when the car is on and i open the doors, the lights on the dash go off. I have no lights function in the doors or dome. dimmer switch does work and so does the bright button(cuases a little bit more light on the clock as well.)

5)Security system dosnt arm with the remote. lock and unlock however does work. When i hit the secuirty button on the dash it blinks repetitivly and quickly.( im not that worried about fixing this one.)


Other then these weird gremlin glitches the car runs great. I suspect i blew out a control module somewhere along the way and its a matter of finding out which ones.

BTW no fuses blew other then the fusable link, so i find these problems very odd as if the power made it past hte fusable link it would have blown any fuse that gets power when the battery is connected.


if you can help me at all it would be much apreciated . Im in madison wi.
phil
* Registered users of the site do not see these ads.
5spd Alcyone is offline  
Old 04-03-2004, 08:30 AM   #2
GLwagon
Scooby Specialist
 
Member#: 16696
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Baraboo, WI
Vehicle:
2002 WRX Sedan Stg2
2013 OBW roll'n at 30+mpg

Default Re: battery got hooked up backwards, need help finding gremlins

Quote:
Originally posted by 5spd Alcyone


odd as if the power made it past hte fusable link it would have blown any fuse that gets power when the battery is connected.
The best gess is that the hand full of fuses for all of the peices = more than main fuseable link

Reguardless, not knowing the internals of an SVX you may endup replacing every module in the car...

I'd start by taking out the stereo & doing some tests on the car...
Try & find the back feeds/broken circuits from the toasted diodes.
Keep pulling parts untill the problems go away & replace as necessarry.
GLwagon is offline  
Old 04-03-2004, 12:38 PM   #3
5spd Alcyone
Scooby Newbie
 
Member#: 34383
Join Date: Mar 2003
Chapter/Region: MWSOC
Location: Madison, WI
Vehicle:
1992 SVX-T3/T04E
Dark Teal Metallic

Default

Every single problem fixed. All hot circuit fuses were not visibally blown but upon replacement work. Including my secuirty system(which nevr worked)
phil
5spd Alcyone is offline  
Old 02-10-2007, 08:05 PM   #4
doogsdouglas
Scooby Newbie
 
Member#: 138462
Join Date: Jan 2007
Location: Newport, RI (for now)
Vehicle:
1998 Legacy OB 2.5l
Redish

Default Similiar Problem

What was the first thing you looked for once you hooked the battery up wrong?
doogsdouglas is offline  
Old 02-10-2007, 09:28 PM   #5
BlkTS02
Scooby Specialist
 
Member#: 50142
Join Date: Dec 2003
Chapter/Region: South East
Location: West TN
Vehicle:
2002 2.5TS
MBP

Default

Smoke?

This thread is almost three years old, you might keep that in mind when you're posting in threads you found while searching.
BlkTS02 is offline  
Old 02-10-2007, 09:35 PM   #6
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

+1, please don't bump ancient threads and expect a response from the original poster.
Mulder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What my BCS lines are hooked up backwards? live_2race Texas Impreza Club Forum -- TXIC 5 08-22-2008 03:36 AM
I got the hook up! Anyone need a detail? mykrrrr Mid West Subaru Owners Club Forum -- MWSOC 11 09-20-2006 09:08 PM
so sdfi just got the treo 600 and i need help find a free version of AIM for it. bubba03wrx Off-Topic 2 08-21-2004 06:43 PM
AVCS hook up problem need help fatray Factory 2.0L Turbo Powertrain 5 05-03-2004 02:39 AM
Autometer a/f ratio gage- best location to hook up power. Need help quick-please. odin1 Electrical & Lighting 11 12-09-2003 12:17 AM


All times are GMT -4. The time now is 10:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.