Welcome to the North American Subaru Impreza Owners Club Friday November 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2004, 12:15 PM   #1
bongchild
Scooby Newbie
 
Member#: 28352
Join Date: Oct 2002
Chapter/Region: SWIC
Location: Tolleson, Arizona
Vehicle:
1993 1.8 helL (AWD)
'06 Corolla XRS!

Unhappy Holy Crap! A/C kills my engine.....

Hey all,

I got a problem...
I went to turn on my A/C the other day and I heard this loud screeching noise from my engine and then it died. I was able to start it back up again, but when I cut on the A/C or the windshield defroster I got the same noise and the same engine death.
It's weird, the car works fine if i have the fan on and the selector dial is at anything except AC or the windshield defroster. If I turn the fan off and set the selector to either those settings it still works. But as soon as i cut on the fan with the selector at one those settings the engine screeches and dies. *** is wrong with my car?? I'm at 100K miles and I just got the oil changed & the belts serviced. I've been religious with my preventive maintenance. Other than a leaking valve cover gasket, my engine is tip-top. Please help!
* Registered users of the site do not see these ads.
bongchild is offline   Reply With Quote
Old 04-07-2004, 12:31 PM   #2
00RScoupe
Scooby Newbie
 
Member#: 57535
Join Date: Mar 2004
Location: Topeka, KS
Vehicle:
2004 FXT
Maroon

Default

If your A/C compressor is siezed it could put such a load on the car that it would die, and make a horrible noise.

Did it happen only after they serviced the car.?
00RScoupe is offline   Reply With Quote
Old 04-07-2004, 01:26 PM   #3
bongchild
Scooby Newbie
 
Member#: 28352
Join Date: Oct 2002
Chapter/Region: SWIC
Location: Tolleson, Arizona
Vehicle:
1993 1.8 helL (AWD)
'06 Corolla XRS!

Default

Yep. I took it to Jiffy Lube to get the belts serviced. I figured those guys over there knew what they were doing.....
bongchild is offline   Reply With Quote
Old 04-07-2004, 01:45 PM   #4
ommmjido
Scooby Specialist
 
Member#: 35746
Join Date: Apr 2003
Chapter/Region: BAIC
Location: @po Crew
Vehicle:
08 White GRB
Wrong Fitment Crew #001

Default

Jiffy Lube?
ommmjido is offline   Reply With Quote
Old 04-07-2004, 01:50 PM   #5
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by ommmjido
Jiffy Lube?
my thoughts exactly


you realize that jiffy lube is the toilet of automotive service rigth?? and your a/c compressor is more then likley siezed
HndaTch627 is offline   Reply With Quote
Old 04-07-2004, 01:54 PM   #6
bongchild
Scooby Newbie
 
Member#: 28352
Join Date: Oct 2002
Chapter/Region: SWIC
Location: Tolleson, Arizona
Vehicle:
1993 1.8 helL (AWD)
'06 Corolla XRS!

Default

Quote:
Originally posted by ommmjido
Jiffy Lube?
Yeah, yeah... It was right there and I didn't have a whole lot of $ in my pocket so I went for it. So my compressor is seized, eh? I take it that means I need to get it replaced, ja? Of all times, too. I'm out of dough and the hot season is right around the corner....
bongchild is offline   Reply With Quote
Old 04-08-2004, 12:11 AM   #7
marcus12
Scooby Specialist
 
Member#: 45613
Join Date: Oct 2003
Chapter/Region: NESIC
Location: Columbia, CT
Vehicle:
2005 Legacy GT Ltd.
Satin White Pearl

Default

could it be a vacuum issue? My car will stall out sometimes if it's in idle with the a/c or just the heat on...Just a thought.

//marcus
marcus12 is offline   Reply With Quote
Old 04-08-2004, 01:40 AM   #8
redwagon
Scooby Specialist
 
Member#: 2181
Join Date: Aug 2000
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2008 SpecB
DGM

Default

Take it back to Jiffy Lube and make them put it right. Could be they overtightened the belt?
redwagon is offline   Reply With Quote
Old 04-08-2004, 02:42 AM   #9
joubtt
Scooby Specialist
 
Member#: 33901
Join Date: Mar 2003
Location: San Diego
Vehicle:
04 04 STI
No AWD, Not interested

Default

Ditto on the proper servicing but stay away from them afterwards. I've seen some costly damage because some of them were not knowedgeable.
joubtt is offline   Reply With Quote
Old 04-08-2004, 03:56 PM   #10
anders8
Scooby Specialist
 
Member#: 26658
Join Date: Oct 2002
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
1 Love Grassroots
NASA Rally Sport FTW!

Default

Dude, first things first.

Start your car. Open the hood. Watch your belts. Have a friend inside the car turn on the AC. If the AC clutch engages but doesn't turn, then yes, it has seized.

You will need to watch it happen. When you say "the engine screeches" we don't know if that's a belt, the engine, the compressor, or some pulley.

Need more info.
anders8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Killed my engine Lopez75 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 25 07-16-2006 02:21 AM
Oil restrictor killed my engine!!!! bugeyes Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 09-13-2005 04:08 PM
holy crap! I just broke my toe! bleuquila Off-Topic 16 12-19-2003 12:55 AM
OT: Holy crap! 4K to replace my gf's mazda tranny!!! Evegan South East Region Forum 7 07-16-2003 06:23 PM
crap what happened to my engine? scrappy doo Normally Aspirated Powertrain 12 05-13-2003 10:17 PM


All times are GMT -4. The time now is 03:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.