Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2004, 06:17 PM   #1
mmmprza
*** Banned ***
 
Member#: 45778
Join Date: Oct 2003
Location: Renton In Good Ole Washington
Vehicle:
2001 Aspen White GC8
Who made my hoodScoop

Default Anyone had water issues with the InJen intake for the GC's?

Well i have had a InJen intake for MY01 RS sitting in my garage for about a year now. I had it installed for about a month, and i had got concerned about the issue of water getting in the filter(seattle weather).
i have thought about building some type of box to keep the filter dry as possible. Now i know i should be worried about water getting in the filter, but how much should i really worry about this issue. I noticed a pretty good gain from the stock intake, and i hate to let this intake go to waste just sitting around.

Any ideas would be great for this intake to work out for me!!

-J
* Registered users of the site do not see these ads.
mmmprza is offline   Reply With Quote
Old 04-07-2004, 06:27 PM   #2
Ruff
Scooby Specialist
 
Member#: 32131
Join Date: Jan 2003
Chapter/Region: NWIC
Location: Oregon City, OR
Vehicle:
2006 Nissan 350Z
Was 01 2.5 RS

Default

I live in Portland, it has been on my car for around 2 years, and nearly 30k miles. Hasn't caused any probs at all. Like you said, it does show great gains, look over at my profile (the injen intake is my only power mod).
Ruff is offline   Reply With Quote
Old 04-07-2004, 11:18 PM   #3
b_tapper
Scooby Guru
 
Member#: 5291
Join Date: Mar 2001
Location: pittsburgh,pa
Vehicle:
'08 Scion xB
Nautical Blue Metallic

Default

wouldn't worry unless you feel like submerging the whole filter in water for a while lol
b_tapper is offline   Reply With Quote
Old 04-08-2004, 12:14 AM   #4
AndyM
Scooby Specialist
 
Member#: 3219
Join Date: Dec 2000
Chapter/Region: MWSOC
Location: Arlington Heights, IL USA
Vehicle:
2004 Impreza WRX STi
WR Blue Pearl

Default

I did kinda worried when it rained on the harder side but my car is fine. I love it and man power gains are awsomem anything over 4K and the car pulls much much better than before.
AndyM is offline   Reply With Quote
Old 04-08-2004, 09:50 AM   #5
imprezza01
Scooby Newbie
 
Member#: 37776
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: poughkeepsie NY
Vehicle:
2001 2.5Rs
Aspen

Default

I worried about the same thing but I have had mine on for about 6 months and (knock on wood) have had no prolbems. The power gains are awesome, like AndyM said.
imprezza01 is offline   Reply With Quote
Old 04-08-2004, 09:50 AM   #6
mmmprza
*** Banned ***
 
Member#: 45778
Join Date: Oct 2003
Location: Renton In Good Ole Washington
Vehicle:
2001 Aspen White GC8
Who made my hoodScoop

Default

alright...i got bored last night and put it back on. i forgot about resetting the ECU... it had the hick-ups and i could'nt figure it out. so i reset the ECU and now it pulls!!

Thanks for the info!

-J
mmmprza is offline   Reply With Quote
Old 04-09-2004, 11:31 AM   #7
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

post this in the NW forum and ask

i do believe that Erik (RS NW) had this very intake when he went through a 4" mud puddle and hydrolocked his engine...

i wish ya the best of luck
Jamie
Subie Gal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone had any issues with the new tint law in IL? SupaHottSauce Mid West Subaru Owners Club Forum -- MWSOC 12 03-08-2010 12:23 PM
Has anyone had an issue with Bertera service? tsquared80 Dealership Reviews 2 02-04-2009 11:41 AM
Has anyone had warranty issues with a Catch Can installed? obxtoy Warranty Issues & SOA Problems 3 08-10-2005 07:26 PM
Where to buy Injen intake for the RS AndyM Normally Aspirated Powertrain 3 09-02-2003 04:58 PM
anyone got installed pic of ISR Performance's intake for the MY2K yuusaku Technical Forum Archive 4 08-07-2000 09:52 AM


All times are GMT -4. The time now is 11:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.