Welcome to the North American Subaru Impreza Owners Club Wednesday November 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > 'Old School' Subaru Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 04-08-2004, 05:12 PM   #1
Scooby Newbie
Member#: 59043
Join Date: Apr 2004
Location: Delaware
87 XT

Have a Nice Day? 87 subaru XT Ignition Problem

87 subaru XT Ignition Problem....
Can anyone please help? I lent my XT to someone and had to drive 160 miles to pick it up. Ran for 2 years no problems - has 140K miles on it - now it seems like there is no spark coming from coil. Asked a mechanic and he said has never replaced a bad coil in 30 years. Replaced cap, rotor, battery cable, a wire that goes into the distributor to the negative side of coil and a black wire that goes to negative side of coil from a wire panel that has jumpers attached to side of antifreeze storage tank. The new coil was the wrong oneand heated up so hot that I thought it was going to bolw. Checked timing belts, rotor turns and I can smell gas when trying to start. What could it be? Don't have lots of $$ to pay someone to do major diagnostics. Before this, car has NEVER left me stranded. Please Help CHRIS kane@antisocial.com
* Registered users of the site do not see these ads.

Last edited by Flowmastered87GL; 04-09-2004 at 02:41 AM.
KANERULES is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-09-2004, 02:42 AM   #2
WCSS Drunk
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
2005 Baja Sport
Regal Blue Pearl


Hmmm I am not sure... there are alot of people over on the USMB with EA82 vehicles and I am sure one of them has seen this before.

www.ultimatesubaru.net is your best bet if no one answers here
Flowmastered87GL is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Subaru Outback Shifting problem gifters Transmission (AT/MT) & Driveline 5 07-03-2010 04:05 AM
87 subaru gl wagon ignition switch hummer1331 Subaru Conversions 0 03-03-2007 08:59 PM
Free 87 Subaru XT engine SAND_MAN1 Texas Impreza Club Forum -- TXIC 3 03-10-2005 02:38 AM
87 subaru XT Ignition Problem KANERULES Newbies & FAQs 1 04-08-2004 12:14 PM

All times are GMT -4. The time now is 01:16 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.