Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-08-2004, 09:14 PM   #1
imposter
Scooby Newbie
 
Member#: 10642
Join Date: Sep 2001
Location: Omaha Nebraska
Vehicle:
95 Impreza EJ22T
05 LGT, 96 Outback

Default TD05 installed, now I have compressor surge

I finally got around to installing my new TD05-16G. Everythings hooked up right (i think) and Im running 9-10 psi. When I let off the throttle it sounds like a rally car; the bypass valve makes a fluttering noise. Its the stock bpv, and I know a few people here have a similar setup. Any ideas of whats causing this and how to fix it?

Thanks,
Jim
* Registered users of the site do not see these ads.
imposter is offline   Reply With Quote
Old 04-12-2004, 12:25 PM   #2
Unsung Boxer
Scooby Specialist
 
Member#: 37196
Join Date: May 2003
Location: WA state
Default

i dont htink thats compressor surge, i believe that is simply a BOV flutter. its rather normal. I asusme your venting to ATM?

Also, there are many vehicles that run about 8psi w/o a diverter valve from the factory. So many of us suggest that it is semi-safe to run 8psi w/o a BOV at all.

Rember also that the WRX Diverter valve is desgined to recirculate. Are you getting a check engine light right now, and a rough idle? If so, its probably because the BOV is leaking at idle. If you can confirm this, than you need to "Crush" the bov.

-Jake
Unsung Boxer is offline   Reply With Quote
Old 04-12-2004, 10:02 PM   #3
imposter
Scooby Newbie
 
Member#: 10642
Join Date: Sep 2001
Location: Omaha Nebraska
Vehicle:
95 Impreza EJ22T
05 LGT, 96 Outback

Default

Well, the fluttering noise from the blow off valve is the audible part of compressor surge. You can read about it on the Go Fast Bits website, or the book Maximum Boost.

Im using the stock recirculating bypass valve of the legacy turbo, which is probably too small in the first place. Even at 8-10 psi, the TD05 can push alot more air than the stock VF11.

-Jim
imposter is offline   Reply With Quote
Old 04-15-2004, 02:49 PM   #4
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

sooo where did you find the td05 ...
Jaxx is offline   Reply With Quote
Old 04-23-2004, 02:57 PM   #5
Ishamiyal
Scooby Newbie
 
Member#: 43682
Join Date: Sep 2003
Location: Greeville, SC
Vehicle:
2001 RS-T 2.5
Blue

Default

When I installed my VF22 I thought the same thing. The turbo was SOOO much bigger and made such a diff sound, I thought I was getting compressor surge. I switched over to an HKS SSQ BOV at the same time and thought I was hearing what you think you are hearing.

If you have installed a larger IC as well (which I also did) there is a LOT more air under pressure- even if you are running the same general PSI. Your volume of air under pressure is greater, even though the pressure hasn't changed. The blow off takes longer and sounds different cuz there is simply more air. Think of it as 10 cubic feet of air at 15 PSI versus 1 cubic foot of air at 15 PSI. It's the same pressure, there is just more to blow off.

Dunno if that is your issue, but it sounds like it to me.
Ishamiyal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New clutch installed now I have questions Paul Revere Transmission (AT/MT) & Driveline 4 03-19-2010 10:44 AM
compressor surge after fmic install drkwrx Factory 2.0L Turbo Powertrain 7 02-14-2008 04:12 AM
Td05, FMIC, atmospheric BOV....compressor surge? GripGC8 Pre-2002 Factory Turbo Powertrain 4 11-30-2007 07:57 PM
***TGV deletes installed, now i have a check engine/flashing cruise*** All4bSpinnin Engine Management & Tuning 30 05-11-2007 01:10 AM
I have compressor surge! Please help!!! adamsrs Normally Aspirated with bolt-on Forced Induction Powertrain 16 10-10-2001 05:20 PM


All times are GMT -4. The time now is 04:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.