Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-13-2004, 12:37 PM   #1
impresivesoob
Scooby Newbie
 
Member#: 25672
Join Date: Oct 2002
Location: Minneapolis, MN
Vehicle:
00 2.5 rs
blue ridge pearl

Impreza GC8 ????? about O2 senser

About three months ago my check engine light came on and was found to be my O2 senser. My car didn't run rough or anything. I had it replaced and was told that it could have gone bad due to my aftermarket exhaust. (Borla)
So now yesterday my check engine light came on again, still isn't running rough so, I'm worried that it's going to be the same problem (O2 senser). My question is, does having aftermarket exhaust make this problem occur?? And if so, can I do anything about it, without getting rid of my exhaust?? Has anyone else had this problem? I don't have $200.00 for a new O2 senser every three months.
* Registered users of the site do not see these ads.

Last edited by impresivesoob; 04-13-2004 at 12:45 PM.
impresivesoob is offline   Reply With Quote
Old 04-13-2004, 12:55 PM   #2
00RScoupe
Scooby Newbie
 
Member#: 57535
Join Date: Mar 2004
Location: Topeka, KS
Vehicle:
2004 FXT
Maroon

Default

If you havn't had the code pulled you don't know anything.

Since you have Borla headers you could just be getting the P0420 or catylist inefficiency CEL. This is very common. If you do pull the code and find your just like most people with aftermarket headers then go to this thread and check out your options.
http://www.rs25.com/forums/showthrea...threadid=14402

A few of us are trying a mechanical fix that was originally designed for WRXs. So far so good on my car. Been CEL free for right at 400 miles which is more than I got with the PEP MIL eliminator. Currently using the O2 extender from Flat4.
00RScoupe is offline   Reply With Quote
Old 04-13-2004, 01:36 PM   #3
BlkTS02
Scooby Specialist
 
Member#: 50142
Join Date: Dec 2003
Chapter/Region: South East
Location: West TN
Vehicle:
2002 2.5TS
MBP

Default

Autozone can get the rear 02 sensor for a '98 impreza (I'm assuming they're still using the same one through '04) for $55 for a generic one or $65 for the sensor with a oem plug.
BlkTS02 is offline   Reply With Quote
Old 04-13-2004, 01:42 PM   #4
bigdweeb
Scooby Specialist
 
Member#: 31035
Join Date: Dec 2002
Chapter/Region: NESIC
Location: Boston
Vehicle:
13 Ford Explorer
14 ISM STi

Default

I kinda think MY98 may have used a 3 wire connector. The Autozone around me said they didn't stock a sensor for my car and they weren't too clear if they could actually order one for me.
bigdweeb is offline   Reply With Quote
Old 04-14-2004, 12:07 AM   #5
ttboy19
Scooby Specialist
 
Member#: 38043
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2004 impreza rs4sale
'10 Legacy 2.5GT

Default

Check out pony express. MIL Eliminator. Don't think your catback is to blame.
ttboy19 is offline   Reply With Quote
Old 04-14-2004, 02:36 AM   #6
impresivesoob
Scooby Newbie
 
Member#: 25672
Join Date: Oct 2002
Location: Minneapolis, MN
Vehicle:
00 2.5 rs
blue ridge pearl

Default

I don't have borla headers just cat back exhaust
impresivesoob is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
O2 senser problem...any suggestions? Subi01 Service & Maintenance 1 01-26-2004 07:55 AM
Looking For Rear O2 Senser Resister setup Andreas Miko Factory 2.5L Turbo Powertrain 6 10-25-2003 09:55 PM
What size nut is the O2 senser?? WRBLUEWAGON Factory 2.0L Turbo Powertrain 7 02-05-2002 07:30 AM
o2 senser nolimitski Mid West Subaru Owners Club Forum -- MWSOC 0 01-29-2002 11:44 PM
('93-'01) O2 Senser #6 Baby STORER Impreza Forum 14 10-11-2001 05:36 PM


All times are GMT -4. The time now is 07:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.