Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-06-2005, 08:19 AM   #1
hatake
Scooby Newbie
 
Member#: 34811
Join Date: Apr 2003
Location: Denver
Vehicle:
04 Baja T
Black

Default Defective paint (warranty)

Hi,

My 2004 Baja Turbo front hood and both front fenders turned out they were painted too thick. Last summer (within 1/2 year of purchase) it started cracking (consistent hair line crack all over the surface). I thought what a crappy paint, but oh well it's Subaru. Took it to SOA guy the other day, and he just scratched his head and sent my car to the repaint (strip off the paint and do color match on the door, too). Over and over he asked me if I had it repainted with his paint thickness measuring tool in his hand. Dude, just look at it, no sign of repaint. He repeatedly said "this can't be right." What can I say?

My car was one of the first on the lot (purchased Dec 2003), so it could be the first-batch defect. If your hood or where ever is exhibiting this type of symptom, take it to the dealer and have them measure the thickness.

Mine is still under warranty, so I even got 05 Leg GT rent a car - which I find useless as I can't put my mt bike in without wrestling with it. Once again, I reaffirmed that Baja turbo is the only behicle that satisfies all my needs. I don't know what I'd do when I have to buy another car...

Kudos for Subaru (except SOA's asking me over and over if I had them repainted), and a great customer service at John Elway Subaru South (Denver). Service rep Paul was the one who kept me in touch over 2 months on this issue. He is a great guy!
* Registered users of the site do not see these ads.
hatake is offline   Reply With Quote
Old 11-06-2005, 08:42 AM   #2
chrisarella
Scooby Specialist
 
Member#: 35584
Join Date: Apr 2003
Chapter/Region: South East
Location: www.chrisarella.com
Vehicle:
1965 FFR Roadster
Coyote + TR-6060

Default

Wirelessly posted (Treo 600: Mozilla/4.0 (compatible; MSIE 6.0; Windows 95; PalmSource; Blazer 3.0) 16;160x160)

Wow. Most of our paint is too thin. I guess it doesn't matter, it's all bad paint
chrisarella is offline   Reply With Quote
Old 11-06-2005, 09:58 PM   #3
BajaNut
Scooby Specialist
 
Member#: 36905
Join Date: May 2003
Chapter/Region: BAIC
Location: Kirkland, WA
Vehicle:
2014 Outback SAP
leggtnut on lgt.com

Default

Mine has the same issue. I had the factory rep had it re-painted. I got mine in Feb 04, but it was on the lot since dec 03 though. The Factory rep asked me the same question but only once. I hadn't re-painted it either and he didn't use a thikness guage. I was at 50k on mine and they still warrantied it though.
BajaNut is offline   Reply With Quote
Old 11-09-2005, 11:22 PM   #4
hatake
Scooby Newbie
 
Member#: 34811
Join Date: Apr 2003
Location: Denver
Vehicle:
04 Baja T
Black

Default

Really? Sorry to hear that, but good to know it was more systematic than I was lead to believe. It's been a whole week now and it is still at the shop. They guy wanted to make sure all is good including clear bra, which wasn't the "original equipment." OK. I can't really complain - got a loaner Leg GT turbo for a week. Being in the newer, nicer, more powerful car only made me miss my Baja!!
hatake is offline   Reply With Quote
Old 11-10-2005, 12:18 AM   #5
BajaNut
Scooby Specialist
 
Member#: 36905
Join Date: May 2003
Chapter/Region: BAIC
Location: Kirkland, WA
Vehicle:
2014 Outback SAP
leggtnut on lgt.com

Default

I know the feeling. That Leg Gt is really nice. but it just doesn't have the truck bed.
BajaNut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 paint defect? STIFLYBY_RANGER Car Care & Detailing 8 05-06-2008 07:57 PM
I'm going to my local dealership for defect paint nxttruck2002 Warranty Issues & SOA Problems 43 11-20-2006 11:27 PM
Paint Corrosion/Defect?? maxpower45 Interior & Exterior Modification 4 08-21-2005 02:01 PM
paint defect? aznatama Service & Maintenance 13 01-20-2005 10:54 PM


All times are GMT -4. The time now is 09:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.