Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > Technical Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 05-09-2000, 04:27 PM   #1
Dan00RS
Scooby Newbie
 
Member#: 1367
Join Date: Apr 2000
Chapter/Region: MWSOC
Location: Cleveland, OH, USA
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Unhappy Check Engine light at 2400 miles!! What's up??

So I'm driving my 2000 RS along the freeway and my check engine light comes on. It doesn't drive any different, sound any different, or feel any different. I've only got 2400 miles on it. Any ideas? Anybody? Anybody?

I'll be taking it to the dealer in the morning to have them run the diagnostics on it, but I'm trying to figure this one out so I can sound halfway logical when I go there.

Thanks!!
* Registered users of the site do not see these ads.
Dan00RS is offline  
Old 05-09-2000, 04:35 PM   #2
DAUTHI
Scooby Newbie
 
Member#: 840
Join Date: Feb 2000
Location: Everywhere!!!
Vehicle:
GC8! '00 2.5RS
Silverthorne and mud

Thumbs down

Start keeping an eye on your gas mileage. It's gonna start dropping! This is the prelude to your o2 sensor dying. Mine has done the same thing. It's a MY00 thing. I finally got the dealer to admit that the sensor was the problem and order a new one, four months later It came in. I'm going out tomorrow to have it put in. The thing runs so rich I have to keep it above 4k to have any power. It's just like driving a V-tec!! Don't let me scare you, it's not actually a big problem. Just don't let your dealer drag it out too long or it'll get worse. I get 16mpg now, we'll see after tomorrow.

Pete W.
Rochester, NY
DAUTHI is offline  
Old 05-09-2000, 04:44 PM   #3
Dan00RS
Scooby Newbie
 
Member#: 1367
Join Date: Apr 2000
Chapter/Region: MWSOC
Location: Cleveland, OH, USA
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Question

Thanks. But will the C/E light go away, or does it have a reset? Or does the ECU need to be reset?
Dan00RS is offline  
Old 05-09-2000, 06:02 PM   #4
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Post

If the O2 sensor is bad, the light won't go off until it is replaced.
8Complex is offline  
Old 05-09-2000, 06:04 PM   #5
Dan00RS
Scooby Newbie
 
Member#: 1367
Join Date: Apr 2000
Chapter/Region: MWSOC
Location: Cleveland, OH, USA
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Thumbs down

Well I guess it's a trip to the dealer for me! Oh well, at least it's a warranty replacement.
Dan00RS is offline  
Old 05-10-2000, 07:02 AM   #6
boxerman
Scooby Newbie
 
Member#: 644
Join Date: Dec 1999
Location: Hoboken, NJ, USA
Post

Dan,
Before your go nuts, did you get gas recently? If the cap is not closed correctly the CE light will go on. Just close the cap until it clicks a bunch of time and then drive for a 1/2 hour if the light goes off that was the problem.

Tim
boxerman is offline  
Old 05-10-2000, 10:06 AM   #7
Dan00RS
Scooby Newbie
 
Member#: 1367
Join Date: Apr 2000
Chapter/Region: MWSOC
Location: Cleveland, OH, USA
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Talking

Well I just got back from the dealer and the o2 sensor was the culprit of the C/E light! The tech told me that Subaru recently changed vendors of the o2 sensor because they were having problems with the first batch for the 2000's.

Thanks for all the help guys (DAUTHI, 8complex, and boxerman)!!
Dan00RS is offline  
Old 05-10-2000, 06:37 PM   #8
DAUTHI
Scooby Newbie
 
Member#: 840
Join Date: Feb 2000
Location: Everywhere!!!
Vehicle:
GC8! '00 2.5RS
Silverthorne and mud

Thumbs up

WOOHOO!!! As expected the new o2 sensor has returned all drivability and milage!! Oh, I love my subie again

Pete W.
DAUTHI is offline  
Old 05-11-2000, 10:51 AM   #9
BLITZKRG-RS
Scooby Newbie
 
Member#: 1332
Join Date: Apr 2000
Chapter/Region: SCIC
Location: SF & Oceanside, CA
Vehicle:
2004 STi
WRB

Post

oddly enough, my engine check light came on awhile back, i was suspecting the o2 sensor failure, but now it disappeared after my recent oil change... C/E light hasn't come on since.. its been 3 weeks. anyone has any input for this???
BLITZKRG-RS is offline  
Old 05-11-2000, 01:06 PM   #10
Dan00RS
Scooby Newbie
 
Member#: 1367
Join Date: Apr 2000
Chapter/Region: MWSOC
Location: Cleveland, OH, USA
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Thumbs up

KC, thank you for sharing your experiences with dealers. But my family and I have been working with this dealer for many years and almost everybody there knows us. I trust my technician completely and when I have concerns or if I don't understand something, he lets me watch him do the work. How many other dealers can you say that about? Not many that I've ever heard of. Besides, even if he did try to pull a "fast one" on me, I've got 4 years of my 4 year warranty left so all parts are replaced under warranty (the car is only 4-1/2 weeks old). And he has to send all parts back to SOA to prove the defects for the warranty replacement!

I totally understand where you are coming from though. I've been hosed by Mueller Tire in the past. They claim to have changed the pads and rotors on my former car (Saturn). When I got out of there, the brakes were worse!!! They didn't do anything! So I changed them myself and learned my lesson!

Finally, as for the gas cap, I always click it a good 4 or 5 times. Gotta make sure my trunk monkey doesn't die from gas fumes!!
Dan00RS is offline  
Old 05-12-2000, 12:09 AM   #11
KC
Scooby Guru
 
Member#: 442
Join Date: Oct 1999
Chapter/Region: NESIC
Location: SE Mass/RI
Vehicle:
2013 Crosstrek XV
00 Honda S2000

Post

The most common reason for the CE light to come one is the GAS CAP not going to 3 clicks.

After about 1/2 tank it'll come on. Why? I don't know.

Dan...how well do you trust your dealership and the mechanics there? Think about it.

They say it was an O2. They tighten the cap and reset the CE light. It disappears. They now tell SOA that they had a faulty O2 and they ship on right out. Free one for down the road. All profit to the dealership.

sI have NO TRUST in any dealers. It's after 15 years of dealing with them, I mark the part being replaced, and ask to see it after it's replaced.

If the mark's not there, they didn't replace it. If the marks where I left it on the car, they didn't replace it. I have caught 3 dealers (Non subie) with this trick on different things and different models.

You have every right to get the part back, or to view it after it get replaced. Just say before they fix it that you'd like to see the part.

--KC
KC is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light at WOT in 4th Aarron_M Service & Maintenance 6 01-06-2007 12:44 AM
Check Engine Light on at 1900 miles..!! GregSTi Factory 2.5L Turbo Powertrain 11 08-04-2005 08:36 PM
Check engine light every1500 miles mrtrex Factory 2.0L Turbo Powertrain 7 02-13-2002 01:13 PM
Check Engine Light, less than 400 miles dada21 Mid West Subaru Owners Club Forum -- MWSOC 26 01-01-2001 09:05 AM
Check engine light at 4900 miles? Dolphin Overton Newbies & FAQs 2 10-19-2000 10:36 PM


All times are GMT -4. The time now is 08:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.