Welcome to the North American Subaru Impreza Owners Club Saturday November 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > 'Old School' Subaru Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-20-2004, 07:29 AM   #1
yellowsubaru
Scooby Newbie
 
Member#: 59876
Join Date: Apr 2004
Location: vancouver WA
Vehicle:
1985 subaru GL
tanish yellow

Default Slow

i have an 85 gl front wheel drive with a 1.8 liter, its carburated, and it seems way under powered, are these cars just naturally very slow, and my headlights seem really dim too, i just put a new alternator in it and it reads 12 volts on the dash gauge.
* Registered users of the site do not see these ads.
yellowsubaru is offline   Reply With Quote
Old 04-20-2004, 01:49 PM   #2
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

The volts are low with a new alt... there could be a short of some sort in the system (the volts should read about 14) or the guage could be innacurate... my brat one reads 12 when the car is doing 13.6 volts just because its old.

These cars are kinda sluggish especially if they are automatics.

if the cat plugs up, they get REALLY sluggish
Flowmastered87GL is offline   Reply With Quote
Old 04-20-2004, 03:50 PM   #3
DerFahrer
Scooby Specialist
 
Member#: 30727
Join Date: Dec 2002
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
2000 Legacy B4 RSK
*Formerly subyluvr2212*

Default

Just beat the hell out of it, that's how you get it to go fast... Don't worry, it can take it
DerFahrer is offline   Reply With Quote
Old 04-20-2004, 05:13 PM   #4
yellowsubaru
Scooby Newbie
 
Member#: 59876
Join Date: Apr 2004
Location: vancouver WA
Vehicle:
1985 subaru GL
tanish yellow

Default

yeah thats what ive been doin, but im kinda scared the cv is gonna break pretty soon its geting pretty loud but i hope to have that fixed this week...it also is kinda hesitant, ill get on it and it will bog down and kind of build up power, its a 5 speed also.i guess i cant complain too much about the car, it was free.
yellowsubaru is offline   Reply With Quote
Old 04-21-2004, 08:42 PM   #5
luigigsb
Scooby Newbie
 
Member#: 59956
Join Date: Apr 2004
Location: asheville, Nc
Vehicle:
1986 Gl AWD wagon
grey

Default

ive got a 86 gl and it is a little sluggish if i put regular gas in it so i put medium or premium type in it every other time i get gas.
luigigsb is offline   Reply With Quote
Old 04-22-2004, 03:05 PM   #6
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

I put the cheap stuff (87 octane) in mine and it loves it. It got worse mileage with higher stuff
Flowmastered87GL is offline   Reply With Quote
Old 04-22-2004, 05:39 PM   #7
luigigsb
Scooby Newbie
 
Member#: 59956
Join Date: Apr 2004
Location: asheville, Nc
Vehicle:
1986 Gl AWD wagon
grey

Default

i guess your car is special then isn' t it
luigigsb is offline   Reply With Quote
Old 04-23-2004, 01:44 AM   #8
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

my turbowagons both seemed to like the middle grade stuff I shoulda mentioned... 89 octane here in oregon

And yes my car is special
Flowmastered87GL is offline   Reply With Quote
Old 04-30-2004, 02:12 PM   #9
85 wagon
Scooby Newbie
 
Member#: 60736
Join Date: Apr 2004
Vehicle:
1985 4wd GL Wagon
Brown

Default

I have the same car and the same promblems cv about out...Sluggish and slow....I was looking at the carberator and noticce that only one jet was working...haven't found a fix for it yet
85 wagon is offline   Reply With Quote
Old 05-03-2004, 02:51 AM   #10
Flowmastered87GL
WCSS Drunk
Moderator
 
Member#: 8914
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2005 Baja Sport
Regal Blue Pearl

Default

If the carb is toast best bet rather than a rebuild is just to swap it for a Weber 32/36 DGEV unless you have VERY strict emissions laws where you are (read CA, or anyplace with underhood inspection)
Flowmastered87GL is offline   Reply With Quote
Old 05-05-2004, 10:03 PM   #11
dusktilldawn
Scooby Newbie
 
Member#: 57766
Join Date: Mar 2004
Location: SW Iowa
Vehicle:
1987 GL Wagon 4WD
The Silver Bullet

Default

I swear by my 32/36 DGEV. It really made my car fun to drive again. Well worth the money and time to get it installed..
dusktilldawn is offline   Reply With Quote
Old 05-07-2004, 02:50 PM   #12
wahtor
Scooby Newbie
 
Member#: 60398
Join Date: Apr 2004
Location: NorthWest
Default

My 87 GL carbed sub has had a lack of power as well, kind of a bog from 1/3 throttle to 3/4 throttle. Frustrating because that's where normal highway driving is. Doing a rebuild on it now and I found both heads cracked between the valves. I've heard this is common on these cars if they heat up at all. I also had problems with it dying at idle with the clutch in. A rebuilt carb helped, but Well see what happens when it's all back together. You might check your compression and see what it is.
wahtor is offline   Reply With Quote
Old 05-26-2004, 12:22 AM   #13
anthonyf1
Scooby Newbie
 
Member#: 62728
Join Date: May 2004
Default

mine has the same problem, I have an 81 GL wagon, sometimes it'll lack power below like 3000 rpms, my volt meter reads 12-14 when I drive, but like 6-8 when it sits. I am thinking of replacing all the spark plugs?
anthonyf1 is offline   Reply With Quote
Old 06-07-2004, 04:41 PM   #14
Sexymama
Scooby Newbie
 
Member#: 23361
Join Date: Aug 2002
Location: Albemarle
Vehicle:
1989 dl
white

Default

mny dl seems alittle slow but once i get her up to like 55 or 60 she flies i love my little car !!
Sexymama is offline   Reply With Quote
Old 06-07-2004, 05:27 PM   #15
TurboneX
Scooby Specialist
 
Member#: 21676
Join Date: Jul 2002
Chapter/Region: NWIC
Location: Pacific Northwet
Vehicle:
RX 02Foz,05OB
Black

Default

You guys gotta remember to take off the e-brake
But seriously, replace the carb with a Weber, its the only way your going to get any performance out of it. Put a better muffler on it also. Yes the cracks are common, but it doesnt mean the heads are shot. If the cracks dont travel up into the exhaust port, it hasnt gone into the water jacket. I think every head I've seen has had cracks. It might be a good idea to upgrade the coil. But think twice about the Accel 1840. Alot of these have been going out, some within a year of purchase. Some may argue about the mounting position, but they shouldnt fail either way IMO.
TurboneX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Cars - The Joy of Slow h2o Non-Subaru News & Rumors 49 02-19-2009 02:13 PM
Slow drivers=slow flashers? GooseMan Off-Topic 6 08-09-2005 05:24 PM
Divx movies that go slow then quick then slow then quick then... Trizzle Off-Topic 1 01-26-2004 09:40 AM
KC is SLOW and he drives a Slow Wagon! AWMIII New England Impreza Club Forum -- NESIC 11 04-03-2003 09:32 AM
('93-'01) i club a little slow? WillReckXhop Impreza Forum 0 04-22-2001 09:52 PM


All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.