Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-19-2004, 10:44 PM   #1
vsboxerboy
Scooby Newbie
 
Member#: 38534
Join Date: Jun 2003
Location: Southern California
Vehicle:
2002 WRX Sedan
Silver

Default CEL makes car slower?

Hey-
I put in a catless uppipe and downpipe and yeah Im pretty damn lazy and I havent gotten around to doing the two cel fixes, Ill do it soon becuse I want to know when my car is throwing a CEL for real. Anyway, in the meantime, my car feels a bit more sluggish than it used to. This is odd as with a catless uppipe and downpipe I should be up on power, not down. If this thread has been done before dont bite my face off, just post me a link. Thanks for the help
~Sonny
* Registered users of the site do not see these ads.
vsboxerboy is offline   Reply With Quote
Old 04-20-2004, 10:17 AM   #2
jbogli
Scooby Specialist
 
Member#: 26006
Join Date: Oct 2002
Location: Manchester,CT
Vehicle:
2002 Impreza WRX
Black

Default Leak?

you might have a leak that is causing the loss of power.
Justin
jbogli is offline   Reply With Quote
Old 04-20-2004, 11:45 AM   #3
krazedant
Scooby Specialist
 
Member#: 21218
Join Date: Jul 2002
Location: Queens, NYC
Vehicle:
Baby has been sold
=*(

Default

You might have a leak. Did you replace the gaskets when you changed the uppipe/downpipe? A leak could cause you to lose power and torque.
krazedant is offline   Reply With Quote
Old 04-20-2004, 12:11 PM   #4
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
'08 BMW 135i
F/A-18C

Default

Quote:
Originally posted by jbogli
you might have a leak that is causing the loss of power.
just the CEL won't cause a loss of power

more than likely a leak
Thumper23 is offline   Reply With Quote
Old 04-20-2004, 12:57 PM   #5
MustGoFast
Scooby Specialist
 
Member#: 33370
Join Date: Feb 2003
Location: Milwaukee, WI
Vehicle:
2002 Impreza WRX
Blue now w/ 6 fun flavors

Default

the 2 CEL's related to the uppipe and downpipe wont cause a loss in power, but others could.. if your worried about it get them pulled to ensure nothing else is a problem.

And a leak can kill power and spool... also an ECU reset may help as well for you.
MustGoFast is offline   Reply With Quote
Old 04-20-2004, 01:04 PM   #6
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

i disagree
the EGT sensor error will throw the car into limp mode
Jaxx is offline   Reply With Quote
Old 04-20-2004, 03:13 PM   #7
spelk3
Scooby Newbie
 
Member#: 19835
Join Date: Jun 2002
Chapter/Region: BAIC
Location: Mountain View, CA
Vehicle:
2012 WRX sedan
sold '02 WRX wagon

Default

When I had the EGT CEL my car ran fine, no limp home mode.
spelk3 is offline   Reply With Quote
Old 04-20-2004, 03:44 PM   #8
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

i was on the road in cruze control when my egt sensor died ... it was VERY noticable
Jaxx is offline   Reply With Quote
Old 04-20-2004, 05:12 PM   #9
vsboxerboy
Scooby Newbie
 
Member#: 38534
Join Date: Jun 2003
Location: Southern California
Vehicle:
2002 WRX Sedan
Silver

Default

yeah i definantly have a leak; im still working on getting that fixed just something about reinstalling the uppipe for the fourth time ()just doesnt sound appealing to me (a testament to spend the money on the damn perrin uppipe instead of going the replica way live and learn) anyway i didnt think that the leak would cause a loss of power after the turbo was already spooled...i can see an increase in lag but i figured (power wise) its not doing more than a preturbo wastegate but i guess im wrong. but there does seem to be some argument as to EGT cell causing maybe not necessarily a limp but a noticible diffrence... anyone ahve any evidence to prove/refute this?
vsboxerboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did my swaybar upgrade make me slower? leecea Brakes, Steering & Suspension 10 08-11-2008 09:23 AM
Possible for Cobb AP to make car slower?? zakSti Newbies & FAQs 16 05-30-2007 02:04 PM
Will new wheels make my car slower? bmw50021 Tire & Wheel 22 12-09-2006 04:20 AM
Will 18's make my car slower?? ControlFreak Tire & Wheel 39 02-13-2006 06:12 PM
Need help: just got 02 and CEL makes the car run like crap 17cTSi Factory 2.0L Turbo Powertrain 4 05-26-2004 07:22 PM


All times are GMT -4. The time now is 08:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.