Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2004, 03:31 PM   #1
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default check engine light

well i bought a 2000 2.5rs the other night and so far im lovin it

went to show it off to a few friends but filled up the tank first on the way home an hour or 2 later the check engine light came on so i busted out the owners manual and it said could be emissions control or the gas cap called the dealership they said give it a few days


so guess my question is is this a normal thing that happens after fillin up the tank 3 or 4 clicks of the cap is enough isnt it
* Registered users of the site do not see these ads.
animosity is offline   Reply With Quote
Old 04-21-2004, 04:33 PM   #2
NotAnRS
Scooby Specialist
 
Member#: 1004
Join Date: Mar 2000
Chapter/Region: MAIC
Location: Elizabethtown, PA
Vehicle:
2002 Forester L
Scratch-n-Dent Blue

Default

Gas cap is a common CEL trigger. Just make sure you have it on good and snug. If the light doesn't go off, you can disconnect the battery for several minutes and it should reset.
NotAnRS is offline   Reply With Quote
Old 04-21-2004, 06:09 PM   #3
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

This isn't normal after filling up the tank. And three or four clicks is enough to prevent that particular CE code.

If you have an Autozone nearby, they also pull codes. Can't do anything about it until you know what it is.
Julian is offline   Reply With Quote
Old 04-21-2004, 07:02 PM   #4
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

Well, you didn't say what octane gas you got versus what was in the tank, but most likely it's the gas cap. Yeah, 3-4 clicks SHOULD be enough, but on my wife's OBW I have had to learn to LEAN against the cap and click it 15-20 times to keep the damn CEL away!
1 Lucky Texan is offline   Reply With Quote
Old 04-21-2004, 07:48 PM   #5
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

did you fill it up while the car was running?

if so, thats probably why the light is on. Always turn the car off when you are getting gas.

Jay
munkis is offline   Reply With Quote
Old 04-21-2004, 08:12 PM   #6
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default

Quote:
Originally posted by McDade
did you fill it up while the car was running?

if so, thats probably why the light is on. Always turn the car off when you are getting gas.

Jay

Don't leave it on the A/C position either.
obyone is offline   Reply With Quote
Old 04-21-2004, 10:57 PM   #7
SjYankee006
Scooby Newbie
 
Member#: 33943
Join Date: Mar 2003
Chapter/Region: NESIC
Location: CT
Default

It's probably the gas cap. I get that CEL from time to time after filling up, so often that I'd almost call it normal. I'd get the code pulled though, just in case.
SjYankee006 is offline   Reply With Quote
Old 04-22-2004, 12:20 PM   #8
gixxerg1
Scooby Newbie
 
Member#: 34957
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2003 wrx
mbp

Default

would it automatically go on right after you just filled it with gas or after like say 20 miles?
gixxerg1 is offline   Reply With Quote
Old 04-22-2004, 04:31 PM   #9
m750
Scooby Guru
 
Member#: 2278
Join Date: Sep 2000
Chapter/Region: NESIC
Location: Pepperell MA
Vehicle:
8Sti | 07 allez
White | Comp

Default

Quote:
Originally posted by 1 Lucky Texan
Well, you didn't say what octane gas you got versus what was in the tank, but most likely it's the gas cap. Yeah, 3-4 clicks SHOULD be enough, but on my wife's OBW I have had to learn to LEAN against the cap and click it 15-20 times to keep the damn CEL away!
Time to replace your gas cap.

Quote:
Originally posted by obyone
Don't leave it on the A/C position either.
never had that problem. I leave the radio on while pumping in the summer. It's fine.

Quote:
Originally posted by gixxerg1
would it automatically go on right after you just filled it with gas or after like say 20 miles?
I will go out after 3-4 successful trips. A sussful trip is defined as a complete warm up / cool down cycle without the error occuring. So, if you drive it on 3-4 seperate ocasions with it fully cooling off, between drives, it should clear.
AO
m750 is offline   Reply With Quote
Old 04-22-2004, 07:08 PM   #10
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default

ok went to an autoparts store today and had em read me the code it was p0420 which turned out to be a problem with the catalyste converters so i guess ill go back to the dealership sometime next week ;x
animosity is offline   Reply With Quote
Old 04-22-2004, 08:04 PM   #11
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

Ahhhh, P0420, we know it well.

Do you have a header or exhaust system on the car?

If bone-stock, your emissions system needs work. Less than 80K miles and the dealer should warranty the work, if your car is stock.
Julian is offline   Reply With Quote
Old 04-23-2004, 12:02 AM   #12
incognito
Scooby Newbie
 
Member#: 12952
Join Date: Dec 2001
Location: PA/NYC
Vehicle:
2011 STi
White

Default

Quote:
Originally posted by obyone
Don't leave it on the A/C position either.
yes dont leave the air conditioning on! it will drain your battery.

*cough* ACC position *cough*

and yes leaving the car in the ACC positin can also cause the code to be set.

it can come on right after, or it can come on 3 weeks after.
incognito is offline   Reply With Quote
Old 04-26-2004, 05:07 PM   #13
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default

Quote:
Originally posted by Julian
Ahhhh, P0420, we know it well.

Do you have a header or exhaust system on the car?

If bone-stock, your emissions system needs work. Less than 80K miles and the dealer should warranty the work, if your car is stock.

im pretty sure its all stock the dealer didnt tell me anything was modded on it and i didnt think to ask but yeah the mechanic said if its under 80k its still under warranty yay
animosity is offline   Reply With Quote
Old 04-26-2004, 09:01 PM   #14
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default

Quote:
Originally posted by incognito
yes dont leave the air conditioning on! it will drain your battery.

*cough* ACC position *cough*

and yes leaving the car in the ACC positin can also cause the code to be set.

it can come on right after, or it can come on 3 weeks after.

...smart ass.



But I had to admit, you got me there.
obyone is offline   Reply With Quote
Old 05-08-2004, 11:17 PM   #15
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default

well the problem with the catalyste was fixed.. i think ;p


the mechanic didnt put something back on right or didnt put something back on at all and now my car sounds like a lawn mower when im movin along and sounds like its about to explode when i rev it up :>

have to drive back out the dealership on monday to have em fix it
animosity is offline   Reply With Quote
Old 05-09-2004, 12:03 AM   #16
animosity
Scooby Newbie
 
Member#: 59395
Join Date: Apr 2004
Chapter/Region: MWSOC
Vehicle:
2007 2.5 RS Wagon
Crystal Gray Metallic

Default

ok another quick update i got under the car and was lookin around it seems that where theres a split in the exaust under the engine before it goes to the cc the gasket thats there is either blown or not set right but either way it was working perfectly ok until i left the dealership parking lot


now i wonder if theyre gonna try and charge me for that

and i forgot to mention everytime i let off the gas my car kind of makes a gurgle sound since this little problem friend said its becuase its sucking air back into the engine ;/

any thoughts/input
animosity is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 04:42 PM
Check engine light, VDC light is on, and cruise control and sport light is flashing Legacymun2k6 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 01-30-2010 01:47 PM
check engine light, wierd engine trouble? gipoliceman Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 01-14-2003 10:04 PM
Engine coolant temp sensor check engine light? rhdude Mid Atlantic Impreza Club -- MAIC 2 11-09-2002 03:42 AM
Engine vibrating, check engine light on codemunky Service & Maintenance 2 09-15-2002 08:50 AM


All times are GMT -4. The time now is 09:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.