Welcome to the North American Subaru Impreza Owners Club Tuesday July 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-25-2004, 01:51 AM   #1
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Default oil consumption and synthetic oil

just a fyi for you guys...

when i was running regular dino oil for the first 10k miles, i would consume about 1 qt for every 2k miles (i change oil on 2k mile intervals), but since i switched to synthetic oil (royal purple), i have not used up a drop. same viscosity, same driving habits, same everything, just different oil. just a heads up for some of you guys worried about your cars using up quite a bit of oil.
* Registered users of the site do not see these ads.
happasaiyan is online now   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-25-2004, 02:27 AM   #2
wistful
Scooby Specialist
 
Member#: 745
Join Date: Jan 2000
Location: Royal Oak, MI
Vehicle:
2004 STi
Java Black Pearl

Default

Is it the oil? or is it ur rings sealing properly? I was going through mad oil too in the car till 10Kish too. However, I had gone to synthetic ~ 5K miles.

Don
wistful is offline   Reply With Quote
Old 04-25-2004, 04:03 AM   #3
RichQY
Scooby Specialist
 
Member#: 31948
Join Date: Jan 2003
Location: SoCal
Vehicle:
2004 STi
Aspen White

Default

frequently checked since adding Mobil 1.

burnt no oil even after 2 days track event..
RichQY is offline   Reply With Quote
Old 04-25-2004, 10:05 AM   #4
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Default

i consumed oil in the interval right before i switched to synth...so unless its just a big coincidence, i would say it IS the oil.
happasaiyan is online now   Reply With Quote
Old 04-25-2004, 12:15 PM   #5
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Default

wow, that is a good deal of oil

(goes out and checks his)
Thumper23 is offline   Reply With Quote
Old 04-25-2004, 02:53 PM   #6
travmn
Scooby Specialist
 
Member#: 10964
Join Date: Oct 2001
Location: Chi-town
Vehicle:
06 ForesterXT
'02 Triumph S3

Default

Quote:
Originally posted by happasaiyan
i consumed oil in the interval right before i switched to synth...so unless its just a big coincidence, i would say it IS the oil.
i switched to mobil 1 early on and would still consume oil. i'd go more with the rings finally seating... mine didn't stop consuming lots of oil until i really ran the car hard (~7500 miles or so)..
travmn is offline   Reply With Quote
Old 04-25-2004, 03:54 PM   #7
lstepnio
Scooby Specialist
 
Member#: 10972
Join Date: Oct 2001
Chapter/Region: South East
Location: Tampabay, Florida
Vehicle:
2004 STi (fuxor3d!!)
2004 Forester X

Default

I would guess it would have much more to do with the fact you have 10,000 miles and not the oil itself. I've noticed that my oil comsumption has gone done from 1.5qt, 1.0qt to .5qt between every oil change on conventional oil.

I have some Mobile 1 sitting here waiting to be poured.
lstepnio is offline   Reply With Quote
Old 04-25-2004, 05:05 PM   #8
essogas
Scooby Specialist
 
Member#: 35703
Join Date: Apr 2003
Location: Toronto, Ontario
Vehicle:
2004 WRX STi
Blue/British Black 18's

Default

What grade oil are u using? I'm using Mobil 1 15W50 for summer.
essogas is offline   Reply With Quote
Old 04-25-2004, 07:00 PM   #9
lstepnio
Scooby Specialist
 
Member#: 10972
Join Date: Oct 2001
Chapter/Region: South East
Location: Tampabay, Florida
Vehicle:
2004 STi (fuxor3d!!)
2004 Forester X

Default

I was using 5w30 conventional oil for the winter season durring break in and switching to 10w30 shortly. I considered using a heavier oil and I still might switch depending on what oil analysis looks like after the switch.
lstepnio is offline   Reply With Quote
Old 04-26-2004, 09:22 AM   #10
Thumper23
Scooby Specialist
 
Member#: 11571
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Virginia Beach, VA
Default

Quote:
Originally posted by essogas
What grade oil are u using? I'm using Mobil 1 15W50 for summer.
that's not what the manual says to use
Thumper23 is offline   Reply With Quote
Old 04-26-2004, 09:29 AM   #11
HD-sw20
Gone But Not Forgotten
 
Member#: 37056
Join Date: May 2003
Chapter/Region: MWSOC
Location: 04 2.5 RS
Default

I am still on regular oil at 14K. My car was driking 1qt every 3K miles until I hit 10K miles. Now at 14K It uses none. I'm still on regular Dino oil and don't have any plans to upgrade yet.
HD-sw20 is offline   Reply With Quote
Old 04-26-2004, 09:52 AM   #12
happasaiyan
Scooby Specialist
 
Member#: 37731
Join Date: Jun 2003
Default

hrm. maybe it was just the mileage. i have been driving the car hard since day 1, however.

kinda weird how oil consumption was sort of an on/off switch with using oil and not. oh well, im not complaining.
happasaiyan is online now   Reply With Quote
Old 04-26-2004, 10:12 AM   #13
mindchatter
Scooby Specialist
 
Member#: 36447
Join Date: May 2003
Chapter/Region: RMIC
Location: Denver
Vehicle:
Heav en for the weat
her & Hell for company

Default

I switched to synthetic Amsoil at 4700 miles, and have burned an average of 1/2qt. between changes (every 3-5k). It does seem to be diminishing slightly w/each change though.
mindchatter is offline   Reply With Quote
Old 04-26-2004, 10:43 AM   #14
DISCOPOPE
Scooby Specialist
 
Member#: 43339
Join Date: Sep 2003
Location: mpls, mn
Vehicle:
2oo4 STi
URgt35r w/t3hM3finj3cki0n

Default

i did dino untill 9k,
i have had to add >1q of oil ever.
DISCOPOPE is offline   Reply With Quote
Old 06-17-2004, 10:47 PM   #15
Sanek
Scooby Newbie
 
Member#: 41064
Join Date: Aug 2003
Location: Bay Area, CA
Vehicle:
2004 STi
WRB

Default

Quote:
Originally posted by Thumper23
that's not what the manual says to use
Manual does say to use 50 for severe driving conditions.
Sanek is offline   Reply With Quote
Old 06-18-2004, 12:57 PM   #16
Tobey
Scooby Specialist
 
Member#: 21400
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Seacoast, NH
Vehicle:
2015 WRX Limited
ISM

Default

i changed to mobil 1 synthetic at 1k with my 02' wrx and i burned a quart every 3k. i blamed the consumption on changing over too early, but that's my theory which doesn't mean jack.

i am switching to synthetic at 5k on this engine. i have 2k on my current, standard oil and i am as full as the day i changed it over (at 1k miles).

it seems everyone has a different theory on oil, what to use and when to switch / change....
Tobey is offline   Reply With Quote
Old 06-18-2004, 01:08 PM   #17
jagcars26
Scooby Specialist
 
Member#: 2394
Join Date: Sep 2000
Chapter/Region: MAIC
Location: Bel Air Md.
Vehicle:
2005 Legacy GT wagon
2009 Forester X

Default

Subaru motors are known fr a long(mileage wise) breakin period,hence the oil issue,,,Thats my theory,,,etc

Rudy
jagcars26 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help: odd oil consumption and engine knock silver03bugeye Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 10-22-2009 12:47 AM
Oil consumption and burned sti4bao Service & Maintenance 8 05-03-2007 01:16 AM
Oil consumption and damage? mpower22 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 7 11-09-2004 04:03 PM
WRX, first oil change, and synthetic...... Philip General Forum Archive 2 01-22-2001 08:55 AM
WRX, first oil change, and synthetic...... Philip Normally Aspirated Powertrain 0 01-22-2001 08:47 AM


All times are GMT -4. The time now is 09:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.