Welcome to the North American Subaru Impreza Owners Club Tuesday January 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > Technical Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 09-02-2000, 10:51 PM   #1
R Diamond
Scooby Newbie
 
Member#: 58
Join Date: Jun 1999
Location: Alexandria, VA
Vehicle:
04 STi (blue/gold)
98 2.5RS Turbo (sold)

Cool Stock MY98 EGT and O2 sensor readings!

Just got back from Rallispec, where I had a set of gauges put on. During the 160 mile drive back, I got me some baseline readings for a bone stock MY98 engine. Thought some might find these useful.

The magic EGT is 1400. That's where the car seemed to enjoy staying during 70-80mph cruise. Even during WOT blasts up to 100mph, it didn't go over 1450. Ever.

55mph is 1300-1350 range. Warm idle EGT seems to be 800.

As for fuel pressure, the gauge read between 23psi at idle to 38psi at WOT. Is that what it should read?

As for O2 voltage, at WOT the meter likes to pick a number between .85 and .88 and stay there. I think when the engine was cold it would be .95 to .99... but I need more data to be sure about that.

My engine should be totally stock for another 2 weeks or so. If anyone wants any readings under different conditions, I'll be happy to do some manual datalogging.

Gauges: AutoMeter EGT (with "pro" sender), Fuel Pressure, and Boost; also, a jumptronix A/F meter. TEC2 + turbo on the way.

Richard
<A HREF="http://members.home.net/gopspin">My car</A>
* Registered users of the site do not see these ads.
R Diamond is offline  
Old 09-03-2000, 06:13 AM   #2
SteveS
Scooby Specialist
 
Member#: 6
Join Date: Jun 1999
Location: South Jersey
Vehicle:
2007 BMW Z4 M Coupe
Interlagos Blue

Post

Good numbers. And this just proves that my VDO EGT setup sucks b@lls since it'll read 1250F while cruising at 80MPH. I assumed it was reading about 150-200F low.

All you guys need to quit scheduling with Rallispec! I need them to do some work for me, too. hehehehe
SteveS is offline  
Old 09-03-2000, 08:02 AM   #3
RidinLow
Scooby Guru
 
Member#: 329
Join Date: Sep 1999
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1995 325i
Arctic Gray

Post

Those numbers sound similar to the ones I'm geting for my MY00. It's around 800 at idle and about 1350 at cruising at 60mph up a hill (after running a -3% correction at 3000 rpm... it used to be around 1200 something).

Just be careful tuning it on the road... I got pulled over for doing 75 in a 55 because I was trying to see where the EGTs would stop rising. Thank goodness the cop was cool & gave me the choice of the speeding ticket or a RalliSpec windshield banner ticket.
RidinLow is offline  
Old 09-03-2000, 09:11 AM   #4
Basil
Scooby Specialist
 
Member#: 743
Join Date: Jan 2000
Location: Shrewsbury, Pa
Vehicle:
MY02 WRX Wagon
TXS Stg 2 - 242 whp

Post

hehe - looks like you're doing the same thing I am - I'll be up the 30th to have a fluid change and look at gauges.. What'd the gauges and install end up running you?

Basil
Basil is offline  
Old 09-03-2000, 06:16 PM   #5
SteveS
Scooby Specialist
 
Member#: 6
Join Date: Jun 1999
Location: South Jersey
Vehicle:
2007 BMW Z4 M Coupe
Interlagos Blue

Post

Yeah, my VDO EGT is off, but that's why I bought all those Autometer Phantom gauges recently. I'm going to end up with quite a cockpit when it's all installed.
SteveS is offline  
Old 09-04-2000, 01:00 AM   #6
R Diamond
Scooby Newbie
 
Member#: 58
Join Date: Jun 1999
Location: Alexandria, VA
Vehicle:
04 STi (blue/gold)
98 2.5RS Turbo (sold)

Angry

All together, it was $870. Ouch!

$400 for the autometer gauges, $75 for the gauge pack housing, $92 for the jumptronix, custom faceplate $50, and installing everything above $250. It requires taking off the headers and welding in an egt sensor, etc. Just for kicks, I'm tracking everything I spend on my car at <A HREF="http://members.home.net/gopspin/">my site</A>. It's going to go up very high once the TEC arrives.

The AutoMeter phantom units are very nice. And My EGT gauge actually works, unlike Steve's! The boost/vacuum gauge is kinda cheesy the way it bounces around, though.
R Diamond is offline  
Old 09-09-2000, 02:02 PM   #7
R Diamond
Scooby Newbie
 
Member#: 58
Join Date: Jun 1999
Location: Alexandria, VA
Vehicle:
04 STi (blue/gold)
98 2.5RS Turbo (sold)

Thumbs up

Thought I'd update this thread with a shot of the AutoMeter gauge pod that Rallispec cooked up. Note that this aluminum faceplate is temporary -- they were out of carbon fiber at the time. It doesn't show up well in the photos, but the fit & finish is quite perfect.

<IMG SRC="http://members.home.net/gopspin/images/mods/podclose.jpg" WIDTH="524" HEIGHT="180" ALT="Gauge Pod">

<A HREF="http://members.home.net/gopspin/info/gaugephoto.htm">More photos here</A>
R Diamond is offline  
Old 09-10-2000, 08:24 AM   #8
SteveS
Scooby Specialist
 
Member#: 6
Join Date: Jun 1999
Location: South Jersey
Vehicle:
2007 BMW Z4 M Coupe
Interlagos Blue

Post

Looks great! And it's USEFUL! That's what I'm doing, too. Can't wait to have it done now...
SteveS is offline  
Old 09-10-2000, 12:56 PM   #9
MattC
Scooby Specialist
 
Member#: 158
Join Date: Aug 1999
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 STi
PBP 1999 2.5RS RBP

Post

Damn you Diamond, your stealing my style!

MattC
MattC is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 3 inch DP (Godspeed) w/ bungs for EGT and O2 sensor saint_foo Mid Atlantic Impreza Club -- MAIC 13 07-22-2005 02:04 PM
UTEC Q: does UTEC intercept stock O2 sensor readings? happasaiyan Engine Management & Tuning 6 12-10-2004 01:29 PM
o2 sensor reading? DangeRS Normally Aspirated Powertrain 14 04-15-2003 02:30 AM
Translating the O2 Sensor Readings TurboRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 12-03-2001 06:37 PM
O2 sensor readings for MY99s efoo Technical Forum Archive 3 07-25-2000 08:05 AM


All times are GMT -4. The time now is 04:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.