Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2004, 04:20 PM   #1
Impreza732
Scooby Newbie
 
Member#: 59396
Join Date: Apr 2004
Location: Macungie,PA
Vehicle:
1999 impreza 2.5RS
white

Default funny idle?

I just got a 99 RS and it idles very inconsistently. When i turn the car on it idles between 1500 adn 2000 rpms, but when i stop at a read light or something it drops really low and seems to stumble. The other day it even stalled. The car came with a SAFC, intake and exhaust on it. It also has an air/fuel ration gauge that the dealership disconnected but won't reconnect. Does anyone know wheather its the settings on the SAFC that are messing it up or is it something else.
* Registered users of the site do not see these ads.
Impreza732 is offline   Reply With Quote
Old 04-26-2004, 04:29 PM   #2
SjYankee006
Scooby Newbie
 
Member#: 33943
Join Date: Mar 2003
Chapter/Region: NESIC
Location: CT
Default

Disconnect it and find out maybe? Not getting any CEL's are you?
SjYankee006 is offline   Reply With Quote
Old 04-26-2004, 05:44 PM   #3
Nicklbrso
Scooby Specialist
 
Member#: 44887
Join Date: Oct 2003
Chapter/Region: NESIC
Location: ME
Vehicle:
00 GC6
Silver

Default

I had the same problem you did. I switched out air filters and my problem was solved. Try cleaning out your air filter or replacing it.
Nicklbrso is offline   Reply With Quote
Old 04-26-2004, 06:55 PM   #4
powerlabs
Scooby Specialist
 
Member#: 45790
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2006 Corvette C6 Z51
SUPERCHARGED

Default

I had a similar problem when my air filter got wet. Drying the filter and cleaning the MAF with carburattor cleaner completely solved the problem.
powerlabs is offline   Reply With Quote
Old 04-27-2004, 03:46 PM   #5
Impreza732
Scooby Newbie
 
Member#: 59396
Join Date: Apr 2004
Location: Macungie,PA
Vehicle:
1999 impreza 2.5RS
white

Default

Thanks, im gonna clean the air filter this weekend and see if that solves it
Impreza732 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
funny idle help? BlkFlat4 Factory 2.5L Turbo Powertrain 0 11-15-2005 01:00 AM
funny idle oscillations on Hydra Matrix 1193 Other Engine Management 1 12-01-2004 09:54 AM
funny idle??? impreza2002 Normally Aspirated Powertrain 5 12-14-2002 06:50 PM
funny idle??? impreza2002 Engine Management & Tuning 0 12-13-2002 10:23 PM


All times are GMT -4. The time now is 01:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.