Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-28-2004, 03:33 PM   #1
Cooljo2.5rs
Scooby Newbie
 
Member#: 59806
Join Date: Apr 2004
Location: laredo
Vehicle:
2001 2.5rs
silver with gold pearl

Default 2.5 Backfire problem

my 01 impreza 2.5 keeps on back firing each time I up shift and press the gas petal...it happens aroung 2-3000 rpm shifts, sometimes the check engine light comes on (happened already 4 times this past 2 months) when this occurs. My car farts bad..Any solutions?
* Registered users of the site do not see these ads.
Cooljo2.5rs is offline   Reply With Quote
Old 04-28-2004, 03:46 PM   #2
powerlabs
Scooby Specialist
 
Member#: 45790
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2006 Corvette C6 Z51
SUPERCHARGED

Default

Do you have some kind of exhaust or intake modification? I believe it is normal for cars with no cats / high flow cats to backfire. Usually the cause is an overly lean mixture failing to ignite, leading to fuel on the exhaust pipe igniting in there. Maybe the presence of a high flow cat/no car makes it more perceptible?
powerlabs is offline   Reply With Quote
Old 04-28-2004, 03:56 PM   #3
orndog
Scooby Specialist
 
Member#: 34670
Join Date: Mar 2003
Chapter/Region: South East
Location: Atlanta
Vehicle:
If she smokes she
pokes

Default

It's normal for letting off the gas in gear, not for shifting up. No clue as to the cause myself.
orndog is offline   Reply With Quote
Old 04-28-2004, 05:02 PM   #4
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default

Quote:
Originally posted by Cooljo2.5rs
my 01 impreza 2.5 keeps on back firing each time I up shift and press the gas petal...it happens aroung 2-3000 rpm shifts, sometimes the check engine light comes on (happened already 4 times this past 2 months) when this occurs. My car farts bad..Any solutions?
What code does the CEL throw? If it's bad enough to throw a code, it could be misfiring in one or more cylinders.
obyone is offline   Reply With Quote
Old 04-28-2004, 05:57 PM   #5
Cooljo2.5rs
Scooby Newbie
 
Member#: 59806
Join Date: Apr 2004
Location: laredo
Vehicle:
2001 2.5rs
silver with gold pearl

Default

yes, i have a stromung exhaust, and intake, i bought this car in an auction and i was talking to the previous owner and said that when he changed the spark plugs, one of the wires got stuck and just snapped off. he said he fixed it though but thats b/s. i think he was running on three cylinders, the wire was from cylinder 3.
Cooljo2.5rs is offline   Reply With Quote
Old 04-28-2004, 06:00 PM   #6
Cooljo2.5rs
Scooby Newbie
 
Member#: 59806
Join Date: Apr 2004
Location: laredo
Vehicle:
2001 2.5rs
silver with gold pearl

Default

i have changed the plugs and wires and checked the timing and all of it is correct
Cooljo2.5rs is offline   Reply With Quote
Old 04-28-2004, 07:55 PM   #7
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default

Quote:
Originally posted by Cooljo2.5rs
yes, i have a stromung exhaust, and intake, i bought this car in an auction and i was talking to the previous owner and said that when he changed the spark plugs, one of the wires got stuck and just snapped off. he said he fixed it though but thats b/s. i think he was running on three cylinders, the wire was from cylinder 3.
Running on 3 cylinders would run real rough. So pull the code and work from there.
obyone is offline   Reply With Quote
Old 04-28-2004, 08:23 PM   #8
Defiantguy
Scooby Newbie
 
Member#: 41268
Join Date: Aug 2003
Chapter/Region: South East
Location: Sarasota, FL
Vehicle:
2015 WRX
Silver

Default

Quote:
Originally posted by orndog
It's normal for letting off the gas in gear, not for shifting up. No clue as to the cause myself.
I get some backfires occasionaly when upshifting. Though I run a track pipe.
Defiantguy is offline   Reply With Quote
Old 04-28-2004, 11:25 PM   #9
Pakin
Scooby Specialist
 
Member#: 17315
Join Date: Apr 2002
Chapter/Region: International
Location: Date Line Denies F-22s
Vehicle:
MY95 Impreza 207C
MY05 Forester 257X

Default

Is it a backfire or afterfire?

-paK +3
Pakin is offline   Reply With Quote
Old 04-29-2004, 12:12 AM   #10
MattDell
Scooby Guru
 
Member#: 16803
Join Date: Mar 2002
Chapter/Region: International
Location: London, England
Default

Quote:
Originally posted by Pakin
Is it a backfire or afterfire?

-paK +3

What I was wondering..
MattDell is offline   Reply With Quote
Old 04-29-2004, 06:02 PM   #11
silver04rs
Scooby Specialist
 
Member#: 38825
Join Date: Jun 2003
Chapter/Region: SCIC
Location: Temecula, CA
Default

i wish my car would throw flames when i shifted
silver04rs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.0-2.5 swap problems, STARTER & FUEL INJECTOR STUCK ON??? aarongivey Factory 2.0L Turbo Powertrain 2 07-31-2010 02:16 AM
Cobb 2.5 starting problems psuknak05 Factory 2.0L Turbo Powertrain 46 04-01-2005 06:11 PM
2.5 idle problem markk26 Normally Aspirated Powertrain 4 10-25-2004 08:58 PM
cobb 2.5 install problem HonduHunter Texas Impreza Club Forum -- TXIC 42 10-04-2004 11:27 AM
'04 STI 2.5 motor problems??? alfriedesq STi Forum Archive 5 01-19-2003 02:18 AM


All times are GMT -4. The time now is 08:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.