Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > Technical Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 05-06-2000, 03:33 PM   #1
Ver.III
Scooby Specialist
 
Member#: 1185
Join Date: Mar 2000
Location: North of the border
Vehicle:
I flap my gums
and now I'm a specialist

Post

Did you check the power connections to the AFC? If you get it working, check the connections between the AFC and the map...maf?
* Registered users of the site do not see these ads.
Ver.III is offline  
Old 05-07-2000, 12:40 AM   #2
kkeetha
Scooby Newbie
 
Member#: 332
Join Date: Sep 1999
Location: Seattle
Unhappy URGENT! I need help!

I am having problem with my AFC. I have had the AFC installed for more than 6 months now, but last night the AFC just wouldnt' work. The engine just shut off when I let off gas. Any idea what I should look for?
kkeetha is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Black Wagon Hatch Area? Need help. ohemgeeitsNiko Interior & Exterior Modification 1 06-02-2010 08:22 AM
Urgent! Need help, First aft market radio craped out/put stock in/fr speakers inop.. munkis Car Audio, Video & Security 12 06-06-2001 03:47 AM
!! URGENT !! Need help...installing hitch... Aaron'z 2.5RS Normally Aspirated Powertrain 4 06-05-2001 02:25 PM
('93-'01) Urgent!!! Just wrecked I need help Please!!!! Robmat Impreza Forum 13 04-16-2001 03:38 AM
urgent, need help regarding custom alignment maomaonsx Bay Area Impreza Club Forum -- BAIC 4 03-01-2001 08:23 PM


All times are GMT -4. The time now is 02:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.