Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Miscellaneous > Off-Topic

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-02-2004, 03:22 PM   #1
wrxtuner02
Scooby Specialist
 
Member#: 22700
Join Date: Aug 2002
Chapter/Region: MAIC
Location: West Virginia
Vehicle:
TRD FJ Crusier SE
76 MG Midget Special

Default top speed run 2002 WRX stg 2*vid*

yeah i just found this video on my drive. I do not condone street racing or breaking any laws. this was done on a closed course at night . the names have been changed to protect the guilty

Video
* Registered users of the site do not see these ads.
wrxtuner02 is offline   Reply With Quote
Old 05-02-2004, 03:27 PM   #2
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

closed course my ass.

nice CEL
Handsdown is offline   Reply With Quote
Old 05-02-2004, 03:30 PM   #3
highspeed11
Scooby Newbie
 
Member#: 30937
Join Date: Dec 2002
Chapter/Region: BAIC
Location: Livermore, Ca
Vehicle:
2005 Legacy GT
GRP

Default

I guess I'll watch it tomorrow when it's done buffering.
highspeed11 is offline   Reply With Quote
Old 05-02-2004, 03:34 PM   #4
Cyberdemon
Scooby Newbie
 
Member#: 11701
Join Date: Oct 2001
Location: Long Island NY
Vehicle:
2008 Acura TL-S
2001 Corvette

Default

Is it just me or did that seem like a really long time to get up to speed?
Cyberdemon is offline   Reply With Quote
Old 05-02-2004, 03:37 PM   #5
bruticus
Scooby Newbie
 
Member#: 10640
Join Date: Sep 2001
Chapter/Region: Tri-State
Location: Does MarcellusWallace
Vehicle:
look like a bitch?
Say what again!!

Default

So....what did that prove?

DjB
bruticus is offline   Reply With Quote
Old 05-02-2004, 03:45 PM   #6
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

Quote:
Originally posted by Cyberdemon
Is it just me or did that seem like a really long time to get up to speed?
it's probably the CEL robbing powa!!!
Handsdown is offline   Reply With Quote
Old 05-02-2004, 03:46 PM   #7
wrxtuner02
Scooby Specialist
 
Member#: 22700
Join Date: Aug 2002
Chapter/Region: MAIC
Location: West Virginia
Vehicle:
TRD FJ Crusier SE
76 MG Midget Special

Default

that was back in 2001. my car was at txs stg2 and it dosent prove anything, it proves that i eluded darwin once again and i am still here to talk about it.

ps that was a 4th gear pull
wrxtuner02 is offline   Reply With Quote
Old 05-02-2004, 03:55 PM   #8
semabe
Scooby Specialist
 
Member#: 46282
Join Date: Oct 2003
Chapter/Region: SCIC
Location: NESIC Refugee
Vehicle:
2011 STI Limited
Pearlescent Eggplant

Default

If car and driver got a stock 02' wrx up to 145 MPH, why did your stage 2 have trouble with 140? Or is the speedo that inaccurate after 100?
semabe is offline   Reply With Quote
Old 05-02-2004, 04:10 PM   #9
JewPac42
Scooby Guru
 
Member#: 23260
Join Date: Aug 2002
Chapter/Region: BAIC
Location: -=3/1 Jew Crew=-
Vehicle:
Patr ick Willis
for Rookie of the year

Default

Quote:
Originally posted by semabe
If car and driver got a stock 02' wrx up to 145 MPH, why did your stage 2 have trouble with 140? Or is the speedo that inaccurate after 100?
I dont think he shifted into 5th.
JewPac42 is offline   Reply With Quote
Old 05-02-2004, 04:18 PM   #10
Gfunk720
Scooby Guru
 
Member#: 42549
Join Date: Aug 2003
Chapter/Region: Tri-State
Location: You can find me in the 203
Vehicle:
E92 BMW M3
2011 VW TDI Wagon

Default

WRX speedo only goes to 140....but how would C+D hit 145 with the limiter on?
Gfunk720 is offline   Reply With Quote
Old 05-02-2004, 04:19 PM   #11
CoiloverKid
Scooby Specialist
 
Member#: 29650
Join Date: Nov 2002
Chapter/Region: International
Location: Himeji/Osaka, Japan
Vehicle:
Lady Gaga fan club
GDB & RX7

Default

why you didnt shift is beyond me...140 woulda been easy in 5th anyways.
CoiloverKid is offline   Reply With Quote
Old 05-02-2004, 04:24 PM   #12
semabe
Scooby Specialist
 
Member#: 46282
Join Date: Oct 2003
Chapter/Region: SCIC
Location: NESIC Refugee
Vehicle:
2011 STI Limited
Pearlescent Eggplant

Default

Quote:
Originally posted by Gfunk720
WRX speedo only goes to 140....but how would C+D hit 145 with the limiter on?
IIRC, there is no 130 MPH limiter on MT5 sedan. The limiter is on the autos. The slowest WRX they ever tested did 139 mph.
semabe is offline   Reply With Quote
Old 05-02-2004, 05:13 PM   #13
trustWRX
Scooby Specialist
 
Member#: 40431
Join Date: Jul 2003
Chapter/Region: SCIC
Vehicle:
2009 Scion XB

Default

SRT-4 is still teh Fastar!

sorry couldn't resist

Why didn't you shift into 5th?
trustWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo not working after Top Speed Run........... chudlo Transmission (AT/MT) & Driveline 6 03-26-2007 07:30 PM
My stock '05 STi top speed run viddy... UltimateLurker Off-Topic 57 12-07-2005 12:31 PM
Top Speed Run (Videos) speedemon9 Member's Car Gallery 25 05-15-2005 11:05 PM
My Top Speed Run speedemon9 Off-Topic 20 05-09-2005 12:53 PM
Top speed run 139mph & loud noise UU AR EX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 92 06-06-2002 03:52 AM


All times are GMT -4. The time now is 05:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.