Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-08-2004, 04:12 AM   #1
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default Calling all jdm ecu users

I need some advise. Should I keep the AVCS on my motor and deal with the lack of engine managment (E.M) or pull off the AVCS cam gears and replace them with some jun cam gears? In doing so I can use my current setup(utec) and save some $$. But I will lose the low and midrange punch. Which brings me to my next set of questions.

I know there are a few people on the board using the jdm ecu w/AVCS and using aftermarket engine managment. AZscoobie, Sponaugle, Cronic etc. If you have input please advise.

1) What are you using for E.M ? utec, ecutec, both, jdm spec utec other(please specify) Downshift1 has tried his old utec on his jdm ecu and had some weird cels.

2) If you are running a utec do you have any problems, such as injector resistors codes massive knocking and weird idle issues. If not what version utec is it and what did you do to get it to work.

3) Im really not looking to get to complicated but do you think a standalone is best. M400 or GEMS

Im sure as this thread gets answered I will have more questions but Im tired now and my brain hurts. This is the last part I need to complete my year long quest for all the right parts to finish my car. Any help would be great!
thanks in advance
-nick
* Registered users of the site do not see these ads.
Redline8k is offline   Reply With Quote
Old 05-08-2004, 09:34 AM   #2
cronic
Scooby Guru
 
Member#: 9749
Join Date: Aug 2001
Chapter/Region: SWIC
Vehicle:
-

Default

1- I am usind ECUTEK/ Utec combo.. The Utec is revision 6b, which has the pins in the correct location for avcs..

2- I do believe i have the injector CEL's but i just turned my CEL off completly with the Utec.. Other than that i have no problems. All i did to get it to work was plug it in.

3- I am not sure of your goals, state inspection laws,etc. For me a standalone is just too much for what i am trying to do..

What mods are you doing to the JDM motor, Turbo upgrade, injectors,etc?

D-
cronic is online now   Reply With Quote
Old 05-08-2004, 09:57 AM   #3
Soon2Bgreat
Scooby Specialist
 
Member#: 2258
Join Date: Sep 2000
Chapter/Region: Tri-State
Location: Irvington, New York, USA
Vehicle:
1999 gc8 ver7 6mt
GT35R 504.7whp;)

Default

Quote:
Originally posted by cronic
1- I am usind ECUTEK/ Utec combo.. The Utec is revision 6b, which has the pins in the correct location for avcs..

2- I do believe i have the injector CEL's but i just turned my CEL off completly with the Utec.. Other than that i have no problems. All i did to get it to work was plug it in.

D-
Soon2Bgreat is offline   Reply With Quote
Old 05-08-2004, 11:40 AM   #4
MK19_
Scooby Specialist
 
Member#: 49148
Join Date: Nov 2003
Chapter/Region: South East
Location: Plantation, FL
Vehicle:
Dogs are forever in
the pushup position...

Default

I am running a V8 (I think) JDM STi ECU with an EcuTek flash on it- still have yet to hook up my AVCS, but the car seems to run great. I do feel as though I need an "on the dyno" tune as opposed to a flash "out of the box" as it were. What is the motor setup you are running?
MK19_ is offline   Reply With Quote
Old 05-08-2004, 02:42 PM   #5
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

thanks guys keep the info coming. As far as my build goes its the whole deal. motor, trans, turbo, injectors and all the bolt ons to support around 400hp on race gas. my goal is mid to high 11's and to have a fun street car/ weekend track car. This will not be my main sorce of transport.

Cronic- doesnt the car run bad with those cels? can you please check and see what codes you are throwing? In interested in knowing.

What are you guys using for knock control, because the factory ecu stops "listening" for knock after 6k or so? Does the ecutec have any added feaures like this?

thanks
-nick
Redline8k is offline   Reply With Quote
Old 05-08-2004, 03:21 PM   #6
cronic
Scooby Guru
 
Member#: 9749
Join Date: Aug 2001
Chapter/Region: SWIC
Vehicle:
-

Default

THe cels are for Injector something, one cel for each injctor and the car runs fine like that..

What turbo are you running?

I thought the Utec listens for knock till redline...
cronic is online now   Reply With Quote
Old 05-08-2004, 03:50 PM   #7
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

I have a HKS 2540r setup and a few tricks (no nos)
the utec might but does the ecutek? Im trying to get the best of both worlds. Id like to have 2-3 maps for different driving days and such. This I cant do with the ecutek all that easily. I still have to check what version utec Im running it see if they are compatiable. Im still up in the air about this whole thing.
thanks for the info keep it coming
-nick
Redline8k is offline   Reply With Quote
Old 05-09-2004, 12:59 PM   #8
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

bump
Redline8k is offline   Reply With Quote
Old 06-01-2004, 12:26 AM   #9
Redline8k
Scooby Specialist
 
Member#: 2968
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Elgin,Illinois
Vehicle:
Beat it to fit,
Paint it to match!

Default

still looking for more good info... anyone.... bueller....bueller...
Im this >< close to buying the JDM/AUS utec any final thoughts?
thanks

-nick
Redline8k is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling all Tablet PC users! gills Off-Topic 46 10-29-2008 12:08 PM
calling all emanage blue users - idle problems mxpunk Normally Aspirated with bolt-on Forced Induction Powertrain 10 11-16-2007 09:03 PM
Calling all JDM V7 and up ECU owners Hyper Subaru Conversions 0 10-20-2006 12:58 AM
Calling all K&N Typhoon users BlueDonkeyWRX Factory 2.5L Turbo Powertrain 13 02-21-2006 10:59 AM
Calling all motorola Razr users tommy2hotty Off-Topic 41 01-19-2006 12:02 AM


All times are GMT -4. The time now is 10:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.