Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-15-2004, 10:46 PM   #1
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default OEM trailer hitch install, 02 WRX sedan

I wasn't quite sure where to put this, but hopefully a search will show it if someone is looking in the future.

Contrary to popular belief, the Subaru L1010SS00 Impreza hitch will in fact fit the 02 WRX sedan. All the parts sites list it for wagon body only, because only the 02 wagon has the pre-wired 6 pin conductor set up for the converter.

As an FYI, the hitch cannot be installed with the factory underspoiler on the car (the piece that is gray and looks like a diffuser). The mounting brackets interfere greatly. I'm holding out hope that a body shop may be able to cut/trim and make it work, but if not...oh well.

From a wiring perspective, I have one tiny question: in the main harness that services the tail lights, blue/red is said to be the 12v (battery) lead for the wagon. The sedan does not have this in the harness. Anyone know of a place I can tap other than the battery itself? Everything else was a snap.

Let me know if you have questions. If I need to, I'll just bust out the multimeter and go for it. I can take some pics if you want to see them.

Scott
* Registered users of the site do not see these ads.
sdecker is offline   Reply With Quote
Old 05-16-2004, 09:54 PM   #2
MRF582
Scooby Guru
 
Member#: 48219
Join Date: Nov 2003
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
. Always drive
the race line .

Default

how much is this hitch? and will it fit an 04 you think?
MRF582 is offline   Reply With Quote
Old 05-17-2004, 09:02 AM   #3
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default

The instructions I received had an addendum for 2004 Impreza, so I'd say that yes, it will fit. It will drop right in on a wagon, and from a mounting standpoint, it will fit the sedan, too. Electrically, the sedan will require you to splice some wires...possibly. I have heard that 03 and later cars all have the 6 pin connector in place, but can't confirm it. The 02 sedan certainly doesn't, which is my problem.

Bump for info on the 12v lead in the back of the car.

Scott
sdecker is offline   Reply With Quote
Old 05-17-2004, 09:29 AM   #4
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

If the sedan has a trunk light, there should be an always-on wire for it in the rear harness. Maybe someone with a wiring diagram could confirm this.
avk is offline   Reply With Quote
Old 05-17-2004, 01:17 PM   #5
UGotBoost?
Scooby Specialist
 
Member#: 45735
Join Date: Oct 2003
Location: ANYWHERE BUT Newport News
Vehicle:
2002 Impreza WRX
Blue

Default

I'm doing the same install (with a draw-tite hitch). I could really use a "how to" for finding all the correct lighting wires in the back.

Thanks in advance
UGotBoost? is offline   Reply With Quote
Old 05-17-2004, 01:24 PM   #6
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default

Quote:
Originally posted by UGotBoost?
I'm doing the same install (with a draw-tite hitch). I could really use a "how to" for finding all the correct lighting wires in the back.

Thanks in advance
This is what I used...

http://www.scoobymods.com/forums/arc...php/t-192.html

It's good for everything but the 12v lead...which I am working on.

The trunk light may be a possibility, assuming it's not switched...I'll meter it this afternoon and see.
sdecker is offline   Reply With Quote
Old 05-21-2004, 09:55 PM   #7
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

That hitch will work on a STi as well. I just installed mine. Don't cut the bumper you don't need too. FYI. And I am about to try to wire the harness in because the STi does not have the 6-pin connectors.

Just thought I'd let everybody know.

Thanks for the info,
Justin
crystalhelix is offline   Reply With Quote
Old 05-22-2004, 05:16 PM   #8
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default

^^^

Rock on!
sdecker is offline   Reply With Quote
Old 05-22-2004, 09:17 PM   #9
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

Everything works!! - The power and brakes of the STi make it feel like the trailer isn't even there. Don't cut your bumper. And you will have to wire up the relay box your self.

Good luck everybody,
Justin
crystalhelix is offline   Reply With Quote
Old 05-25-2004, 08:17 AM   #10
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default

Quote:
Originally posted by crystalhelix
Everything works!! - The power and brakes of the STi make it feel like the trailer isn't even there. Don't cut your bumper. And you will have to wire up the relay box your self.

Good luck everybody,
Justin
Justin, what did you use for 12v back there? Just wondering.

Thanks,

Scott
sdecker is offline   Reply With Quote
Old 05-25-2004, 08:55 AM   #11
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

I had to run a power line from the battery.

The trunk light isn't constant and neither was anything else I found back there

But it wasn't so bad, I only removed the front door plastic.

Good luck,
Justin
crystalhelix is offline   Reply With Quote
Old 05-25-2004, 09:17 AM   #12
sdecker
Scooby Specialist
 
Member#: 14717
Join Date: Jan 2002
Chapter/Region: South East
Location: Road Atlanta
Vehicle:
2002 WRX, WR Blue
Complete n00b Racing

Default

Quote:
Originally posted by crystalhelix
I had to run a power line from the battery.

The trunk light isn't constant and neither was anything else I found back there

But it wasn't so bad, I only removed the front door plastic.

Good luck,
Justin
Arghhhhh

Oh well, not a big deal. It's not like I need to use 000 or anything.

Thanks!

Scott
sdecker is offline   Reply With Quote
Old 05-25-2004, 10:59 AM   #13
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

I don't even know where you can get 000

Have fun,
Justin
crystalhelix is offline   Reply With Quote
Old 05-25-2004, 02:50 PM   #14
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

Justin: do you mean the light doesn't come on if you open the trunk with ignition switch in the "off" position?
avk is offline   Reply With Quote
Old 05-25-2004, 03:44 PM   #15
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

If you wire to the trunk light and shut the trunk, it loses power regardless to the ignition. I tested it with meter and shut the trunk. Do you plan on towing with your trunk open?
crystalhelix is offline   Reply With Quote
Old 05-25-2004, 04:20 PM   #16
avk
Scooby Specialist
 
Member#: 17252
Join Date: Apr 2002
Chapter/Region: Tri-State
Location: NJ
Vehicle:
'06 WX8
59E

Default

Quote:
Originally posted by crystalhelix
If you wire to the trunk light and shut the trunk, it loses power regardless to the ignition. I tested it with meter and shut the trunk. Do you plan on towing with your trunk open?
If the switch is on the ground side, one of the wires at the light should always have 12V. If the switch is on the positive side, you get nothing at the light when it's off but then there should be 12V at the switch. I only said there should be 12V in the rear harness, not necessarily at the light.
avk is offline   Reply With Quote
Old 05-25-2004, 05:30 PM   #17
crystalhelix
Scooby Guru
 
Member#: 35313
Join Date: Apr 2003
Chapter/Region: MAIC
Location: SpryRacing.com AgileAuto.com
Vehicle:
Spry Forester
Silver Spark

Default

ahh, yeah but I was too layz-e
crystalhelix is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So Cal: Oem Trailer Hitch for 02-07 Impreza.....$100 local pickup only PartsDept Exterior/Styling 4 10-21-2007 11:24 PM
FXT DC-MD-VA area help with OEM Trailer Hitch Install? JDaltonRobertson Forester Forum 1 10-18-2005 10:38 AM
Subaru OEM Trailer Hitch Installation jmcomp124 Forester Forum 5 06-08-2004 08:09 AM
trailer hitch on '02 wrx sedan lettucemanatee Newbies & FAQs 1 03-19-2004 12:21 AM
does subaru sell a trailer hitch for the WRX sedan? Mr.Freeze Interior & Exterior Modification 1 05-28-2002 09:03 AM


All times are GMT -4. The time now is 05:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.